If page has a popup window, page stops loading when popup appears

RESOLVED WORKSFORME

Status

()

Core
Networking
P3
critical
RESOLVED WORKSFORME
18 years ago
16 years ago

People

(Reporter: Mike Pinkerton (not reading bugmail), Assigned: Scott MacGregor)

Tracking

({regression, smoketest, top100})

Trunk
PowerPC
All
regression, smoketest, top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-][rtm-], URL)

(Reporter)

Description

18 years ago
- go to www.aol.com (or fool.com, or netscape.com) or any page that pops up a 
little ad window
- close the annoying popup window

expected results:
- page should complete

actual results:
- page never finishes loading
(Reporter)

Comment 1

18 years ago
this is pretty bad
Keywords: nsbeta3, regression
(Reporter)

Comment 2

18 years ago
ok, this doesn't always happen, but it happens a lot. fool.com is a good one 
where i see it a lot, and so are the article pages on Bigbrother2000.com (such as 
http://webcenter.bigbrother2000.aol.com/entertainment/NON/article422.html). The 
bigBrother ones do it more often, since the popup fires very early in the page 
load sequence.
(Reporter)

Comment 3

18 years ago
when the page does finally load (takes over a minute if you let it sit there),
this is what I get in the content area:

/* handles drop down menu hrefs */ function JumpTo(formName) {
listIndex=document.forms[formName].elements[0].selectedIndex; listValue =
document.forms[formName].elements[0].options[listIndex].value; if (listValue !=
'null') location.href = listValue } function showHideLayers() { /* v2.0 */ var
i, visStr, args, theObj; args = showHideLayers.arguments; for (i=0;
i<(args.length-2); i+=3) { /*with arg triples (objNS,objIE,visStr) */ visStr =
args[i+2]; if (navigator.appName == 'Netscape' && document.layers != null) {
theObj = eval(args[i]); if (theObj) { theObj.visibility = visStr; } } else if
(document.all != null) { /* IE */ if (visStr == 'show') { visStr = 'visible';}
/* convert vals */ if (visStr == 'hide') { visStr = 'hidden'; } theObj =
eval(args[i+1]); if (theObj) { theObj.style.visibility = visStr; } } } }
function swap(which_image,flip) { if (rollover=="yes" && preload=="1") {
document[which_image].src=eval(which_image + "_" + flip + ".src"); } } function
preloadImages() { /* v2.0 */ if (document.images) { var imgFiles =
preloadImages.arguments; if (document.preloadArray==null) {
document.preloadArray = new Array(); } var i = document.preloadArray.length;
with (document) { for (var j=0; j< (swapImage.arguments.length-2); i+=3) {
objStr = swapImage.arguments[(navigator.appName == 'Netscape')?i:i+1]; if
((objStr.indexOf('document.layers')==0 && document.layers==null) ||
(objStr.indexOf('document.all')==0 && document.all==null)) { objStr =
'document'+objStr.substring(objStr.lastIndexOf('.'),objStr.length); } obj =
eval(objStr); if (obj != null) { swapArray[j++] = obj; swapArray[j++] =
(oldArray==null || oldArray[j-1]!=obj)?obj.src:oldArray[j]; obj.src =
swapImage.arguments[i+2]; } } document.swa

Looks like the page is only partially loaded.

Comment 4

18 years ago
AOL is top 100, and home.netscape.com is smoketest B.2.
Keywords: smoketest, top100

Comment 5

18 years ago
Hmmm.... this seems like a dup of 39039. mscott would you confirm it so? 

Comment 6

18 years ago
mscott: even though the related bug 39039 is marked future, I am going to
suggest a plus for this one.
Assignee: gagan → mscott
Whiteboard: [nsbeta3+]

Comment 7

18 years ago
Not holding PR3 for this. Marking nsbeta3-. Please nominate for rtm if we really
have to fix this before Seamonkey ships.
Whiteboard: [nsbeta3+] → [nsbeta3-]
(Reporter)

Comment 8

18 years ago
nominating for rtm. it makes aol and netcenter look bad.
Keywords: rtm

Comment 9

17 years ago
Phil, your comment sounds like you don't think we need this.  Could you elaborate?
Whiteboard: [nsbeta3-] → [nsbeta3-][rtm need info]

Comment 10

17 years ago
I was arguing against nsbeta3++, but it sounds like a good one to get for RTM.
(Assignee)

Comment 11

17 years ago
On my Mac (windows and linux too) the page is always drawn before the popup
comes up. So the popup doesn't interrupt the main page.

Mike, are you able to see this using our network connnection or using a modem
from home?
(Reporter)

Comment 12

17 years ago
modem, usually. another good one is www.fool.com. their popup does it a lot.

Comment 13

17 years ago
Scott, is it time to give this one up for RTM?  Are there workarounds for people
using slow links?
(Assignee)

Comment 14

17 years ago
rpotts and I finally have a theory as to what may be going on. Unfortunately, it
requires some heavy changes to the docshell which I don't believe PDT would be
willing to take at this poing in the game.

It seems to only bite Mac users on slow connections (like a modem line) and
that's only sometimes, not all the time. I've yet to be able to reproduce it in
the office. I'm not saying that justifies the minus in and of itself though.

I would recommend a rtm- at this time and we'll hit it in the next release.

Comment 15

17 years ago
ok, then I'll change to an rtm-. If it requires the changes you say then I don't
think it's worth doing this today.
OS: All
Whiteboard: [nsbeta3-][rtm need info] → [nsbeta3-][rtm-]

Comment 16

17 years ago
I'm not seeing this with current mozilla mac builds but my connection is pretty
fast.  Is anyone still seeing this?

Comment 17

17 years ago
mass move, v2.
qa to me.
QA Contact: tever → benc

Comment 18

16 years ago
Closing as WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.