Bad escaping in xpinstall dialog

VERIFIED FIXED in 5.3

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: fligtar, Assigned: wenzel)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
I know we've fixed this bug before (years ago), but it seems to have resurfaced.

http://www.squarefree.com/temp/poor-escaping.png
Created attachment 407890 [details]
Attaching screenshot locally
(Assignee)

Comment 2

9 years ago
Probably due to the install button rewrite?
(In reply to comment #2)
> Probably due to the install button rewrite?

Most likely, yes. Now that it's been rewritten, it should be super easy for anyone else to edit the code! :)
(Assignee)

Comment 4

9 years ago
Created attachment 408029 [details] [diff] [review]
Patch, rev. 1

There you go.
Assignee: nobody → fwenzel
Status: NEW → ASSIGNED
Attachment #408029 - Flags: review?(rdoherty)
Comment on attachment 408029 [details] [diff] [review]
Patch, rev. 1

Looks good and works, thanks for fixing this Wenzel!
Attachment #408029 - Flags: review?(rdoherty) → review+
(Assignee)

Comment 6

9 years ago
Excellent. r54084.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: push-needed
Resolution: --- → FIXED
Duplicate of this bug: 526104
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.