Last Comment Bug 523984 - Old (1.9.0/1.8.1) Default Plugin.plugin Makefile uses non-portable "echo -n"
: Old (1.9.0/1.8.1) Default Plugin.plugin Makefile uses non-portable "echo -n"
Status: RESOLVED FIXED
: verified1.8.1.24, verified1.9.0.16
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: 1.9.0 Branch
: All Mac OS X
: -- normal (vote)
: ---
Assigned To: Smokey Ardisson (offline for a while; not following bugs - do not email)
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-22 16:41 PDT by Smokey Ardisson (offline for a while; not following bugs - do not email)
Modified: 2010-02-25 13:47 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Replace "echo -n" with "printf" (843 bytes, patch)
2009-10-22 16:41 PDT, Smokey Ardisson (offline for a while; not following bugs - do not email)
jaas: review+
samuel.sidler+old: approval1.9.0.16+
samuel.sidler+old: approval1.8.1.next+
Details | Diff | Splinter Review

Description Smokey Ardisson (offline for a while; not following bugs - do not email) 2009-10-22 16:41:41 PDT
Created attachment 407892 [details] [diff] [review]
Replace "echo -n" with "printf"

The old Default Plugin.plugin's Makefile use the non-portable "echo -n" syntax in its Makefile to create its PkgInfo file; this results in a bogus string in PkgInfo when building on 10.5 (see bug 501457, where this behavior was first diagnosed).

Because of the possibility of Camino being in a position where we have to do our 1.9.0 and any remaining 1.8.1 releases on a 10.5 box, I'd like to get this trivial patch for Default Plugin.plugin in the tree on those branches.
Comment 1 Smokey Ardisson (offline for a while; not following bugs - do not email) 2009-10-24 13:38:39 PDT
Comment on attachment 407892 [details] [diff] [review]
Replace "echo -n" with "printf"

Requesting approval for 1.9.0.16 and 1.8.1.next for this trivial patch to ensure the Mac Default Plugin builds correctly on 10.5.  While other apps build and ship the Default Plugin, PFS overrides it, so Camino is the only actual consumer of this plugin, and this ensures we'll be able to build proper releases on 10.5 tinderboxen on these branches (the output of the two commands is identical on 10.4; see bug 501457).
Comment 2 Samuel Sidler (old account; do not CC) 2009-10-24 16:00:30 PDT
Comment on attachment 407892 [details] [diff] [review]
Replace "echo -n" with "printf"

Approved for 1.9.0.16 and 1.8.1.24. a=ss for this minor change.
Comment 3 Smokey Ardisson (offline for a while; not following bugs - do not email) 2009-10-24 16:40:37 PDT
Checking in modules/plugin/samples/default/mac/Makefile.in;
/cvsroot/mozilla/modules/plugin/samples/default/mac/Makefile.in,v  <--  Makefile.in
new revision: 1.23; previous revision: 1.22
done

Checking in modules/plugin/samples/default/mac/Makefile.in;
/cvsroot/mozilla/modules/plugin/samples/default/mac/Makefile.in,v  <--  Makefile.in
new revision: 1.13.4.2; previous revision: 1.13.4.1
done
Comment 4 Smokey Ardisson (offline for a while; not following bugs - do not email) 2009-10-26 14:41:15 PDT
In the event anyone comes along and is concerned with verifying this fix, the way to do so is to grab tinderbox-builds for each branch from Camino's 10.5 tinderbox[1], and view the contents of Camino.app/Contents/MacOS/plugins/Default Plugin.plugin/Contents/PkgInfo (should be NSPLMOSS).  

For added verification, you could then compare to official nightlies (built on 10.4 boxen) for 1.8.1 (latest-Cm1.6-M1.8/) and 1.9.0 (latest-Cm2.1-M1.9/) and ensure they also still have the right value.

[1] http://ftp.mozilla.org/pub/mozilla.org/camino/tinderbox-builds/cb-xserve04-1.6-M1.8/
http://ftp.mozilla.org/pub/mozilla.org/camino/tinderbox-builds/cb-xserve04-2.1-M1.9/
Comment 5 Al Billings [:abillings] 2009-11-23 10:28:14 PST
Verified for 1.9.0.16 by looking at my 1.9.0.16 build on OS X.
Comment 6 Al Billings [:abillings] 2010-02-25 13:47:29 PST
Verified for 1.8.1.24 using Camino builds (Version 1.6.11pre (1.8.1.24pre 2010022513)).

Note You need to log in before you can comment on or make changes to this bug.