"View Image Info" shows wrong data of image when there are images of same src=url in a document

VERIFIED FIXED in Firefox 3.7a1

Status

()

defect
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: alice0775, Assigned: dao)

Tracking

({testcase})

Trunk
Firefox 3.7a1
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(status1.9.2 beta2-fixed)

Details

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b2pre) Gecko/20091022 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20091022 Minefield/3.7a1pre ID:20091022234402

"View Image Info" shows  wrong data of image when there are images of same src=url in a document.

Reproducible: Always

Steps to Reproduce:
1.Start Minefield with new Profile
2.Open Test Case
3.Carry out a "View Image Info" command in image B
Actual Results:  
The result displays wrong data
Dimensions:       128px × 128px (scaled to 80px × 80px)
Associated Text:Minefield icon 80px

Expected Results:  
The result should be as follows
Dimensions:       128px × 128px (scaled to 200px × 200px)
Associated Text:Minefield icon 200px
Posted file testcase
Version: unspecified → Trunk
Blocks: 517902
Summary: "View Image Info" shows wrong data of image When there is an image of same SRC in a document → "View Image Info" shows wrong data of image when there are images of same src=url in a document
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Windows Vista → All
Hardware: x86 → All
Posted patch patchSplinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #408005 - Flags: review?(db48x)
Component: Menus → Page Info
QA Contact: menus → page.info
I will leave it to db48x for the official review, but FWIW, I quickly went over the patch (since I wrote what you had to fix ;) ), and it looks good to me.
Blocks: 524092
The new testcase for Bug 517902 will be broken by this since it looks for the image src not the element, and I can't use the element until this is fixed, so if the testcase is added, I am happy to provide a patch to make it compatible with this.

Dao: What would you like?
Adding a knowingly broken test for knowingly broken code doesn't make sense to me, so I'd rather do it once this is fixed.
Mconnor wanted the test and it was conditional on this the feature committed but the test took longer than we had anticipated.  If he or beltzner would like to wait on the test for this patch, I'm more than happy to do so.  If they do not, I will gladly fix both the testcase and this patch, so that you don't need to be bothered with all of this.
Comment on attachment 408005 [details] [diff] [review]
patch

r=db48x
Attachment #408005 - Flags: review?(db48x) → review+
http://hg.mozilla.org/mozilla-central/rev/ac98fd60de44
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1
Attachment #408005 - Flags: approval1.9.2?
Verified Fixed on trunk.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20091030 Minefield/3.7a1pre (.NET CLR 3.5.30729) ID:20091030060356
Status: RESOLVED → VERIFIED
Requesting in-testsuite.  The testcase for Bug 517902 should cover this.
Flags: in-testsuite?
I am granting in-testsuite, since the testcase for Bug 517902 covers this: correct?
Flags: in-testsuite? → in-testsuite+
yep
Comment on attachment 408005 [details] [diff] [review]
patch

a192=beltzner
Attachment #408005 - Flags: approval1.9.2? → approval1.9.2+
Depends on: 526534
Depends on: 526721
No longer depends on: 526721
You need to log in before you can comment on or make changes to this bug.