Closed Bug 524123 Opened 12 years ago Closed 12 years ago

[Regression] Opening tabs in background fails to render into tiles

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(fennec1.0+)

VERIFIED FIXED
Tracking Status
fennec 1.0+ ---

People

(Reporter: mfinkle, Unassigned)

References

Details

When opening a tab in the background, the tab thumbnail is created and rendered correctly, but the main tile area is not rendered. Pressing "refresh" will cause the tiles to render.

The page is obviously loaded correctly, just not rendered.

To reproduce, go to http://popuptest.com so the popups open in the background. Or use the new (not landed at time of filing bug) Open in Tab feature (bug 465284)
Blocks: 465284
tracking-fennec: --- → ?
tracking-fennec: ? → 1.0+
It looks like we've had this problem a long time.  See _resizeAndPaint.

>    if (this == Browser.selectedTab) {
>      // !!! --- RESIZE HACK BEGIN -----
>      bv.simulateMozAfterSizeChange();
>      // !!! --- RESIZE HACK END -----
>
>      let restoringPage = (this._state != null);
>
>      if (!this._browserViewportState.zoomChanged && !restoringPage) {
>        // Only fit page if user hasn't started zooming around and this is a page that
>        // isn't being restored.
>        bv.zoomToPage();
>      }
>    }

The code needed to correctly size the viewport and set up zooming is specific to the current browser.  When it's in the background, we simply don't set things up so the browser view is still (0, 0, 1, 1) (you can see a pixel being rendered).

The patch here isn't tough, but I bet my lunch it'd be wasted effort when the patch for bug 480958 lands.  Adding as a dep.
Depends on: 480958
Duplicate of this bug: 524233
http://hg.mozilla.org/mobile-browser/rev/3d8f7d7b2fc7 from bug 480958 fixed this
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b2pre) Gecko/20091104 Firefox/3.6b2pre Fennec/1.0b5

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091104 Firefox/3.7a1pre Fennec/1.0b5
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.