<radio>.setAttribute('value','foo') doesn't update visually

VERIFIED WORKSFORME

Status

()

Core
XUL
P3
normal
VERIFIED WORKSFORME
18 years ago
16 years ago

People

(Reporter: John Morrison, Assigned: David Hyatt)

Tracking

({helpwanted})

Trunk
Future
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Overview Description: 
  Using .setAttribute to change the value of a <radio> does not result
  in a change visually. However, the value is being changed in the DOM.
  No change in the layout occurs whatsoever (as opposed to the <checkbox>
  which just failed to do a reflow).

Steps to Reproduce: 
1) Load the testcase
2) click the test buttons and look at the screen and the console.

Actual Results:   no change to radio label

Expected Results: radio label updated with new value

Reproducibility: always

Build Date & Platform Bug Found: 
  20000912nn mac/linux/win32
(Reporter)

Comment 1

18 years ago
-> Future, as ducarroz and BenB said they don't need it for PR3/RTM.
Target Milestone: --- → Future
(Reporter)

Comment 2

18 years ago
Created attachment 14576 [details]
testcase; update the value attribute of <radio>   [text/xul]

Comment 3

18 years ago
Theme builders need to know this doesn't work, and a suggested workaround would 
be useful.
Keywords: helpwanted, relnoteRTM

Comment 4

18 years ago
Content is the same. Looks like this is a XBL bug. Hyatt?
Assignee: evaughan → hyatt
This bug seems fixed to me. The text in the testcases changes when the buttons 
are clicked. 20001023MN6 Win95.

So, the blurb:
It seems unclear to me whether this bug requires either of a "developer" or 
"user" release note for Netscape 6 RTM. If anyone feels it does, can they please 
draft one and then nominate with the relnote-user or relnote-devel strings in 
the Status Whiteboard.

Thanks :-)

Gerv

Comment 6

16 years ago
worksforme
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 7

16 years ago
Created attachment 60058 [details]
updated testcase
(Reporter)

Comment 8

16 years ago
"Bring out your dead!"
'Here's one.'
"Ninepence."
``I'm not dead!''
"What?"
'Nothing. Here's your ninepence.'
``I'm not dead!''
"Ere. He says he's not dead!"
'Yes, he is.'
``I'm not!''
"He isn't..."
'Well, he will be soon. He's very ill.'
``I'm getting better!''
'No, you're not. You'll be stone dead in a moment.'
"Oh, I can't take him like that. It's against regulations."
Status: RESOLVED → VERIFIED

Comment 9

16 years ago
Why is it that all I can think to say is 'worksforme' and you find a passage 
from Monty Python (no?) to fit the occasion?
(Reporter)

Comment 10

16 years ago
Cause I'm a lazy bastard who's randomly surfing the web instead of retesting 
all my old bugs?

:-)
You need to log in before you can comment on or make changes to this bug.