Weave 0.8pre2 preferences pane closes (and forgets what I've typed) if I press "enter" at any stage of the username/password/passphrase entry process

RESOLVED FIXED

Status

Cloud Services
Firefox Sync: UI
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: dholbert, Assigned: mconnor)

Tracking

unspecified
x86
Linux
Points:
---
Bug Flags:
blocking-weave1.0 +

Firefox Tracking Flags

(Not tracked)

Details

STEPS TO REPRODUCE:
 0. Be running Weave with 0.8pre2, with your account data already entered.
 1. Go to the Firefox Preferences 'Weave' tab
 2. Click "Manage Account" and "Start Over", if you already have an account configured
 3. Enter your Weave username. Press enter.
    --> PREFERENCES DIALOG DISAPPEARS
 4. Repeat steps 1-3  (but don't press enter).
 5. Type in your Weave password. Press enter.
    --> PREFERENCES DIALOG DISAPPEARS
 6. Repeat steps 1-5 (but don't press enter).
 7. Click the "Sign In" button, to get to the passphrase screen. Enter your passphrase. Press enter.
    --> PREFERENCES DIALOG DISAPPEARS
 8. Repeat steps 1-7 (but don't press enter).
 9. Click "Continue"
    --> Finally it worked!  Account is now set up.

EXPECTED RESULTS:
 - Every time the preferences dialog disappeared (and lost all the information I'd entered thus far), it should not have.
Instead, when I press "enter"...
  - ...when username field is focused (step 3): I'm not sure what should happen
  - ...when password field is focused (step 5): it should activate "sign in" button
 -  ...when passphrase field is focused (step 7): it should activate "continue" button
Flags: blocking-weave1.0?
Summary: Weave 0.8pre2 preferences pane closes (and forgets my entries) if I press "enter" at any stage of the username/password/passphrase entry process → Weave 0.8pre2 preferences pane closes (and forgets what I've typed) if I press "enter" at any stage of the username/password/passphrase entry process
(Assignee)

Comment 1

8 years ago
This was fixed.
Assignee: nobody → mconnor
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: blocking-weave1.0? → blocking-weave1.0+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.