Move the bug visibility controls somewhere better

RESOLVED FIXED in Bugzilla 3.6

Status

()

Bugzilla
Creating/Changing Bugs
--
enhancement
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Max Kanat-Alexander, Assigned: Max Kanat-Alexander)

Tracking

Bugzilla 3.6
Dependency tree / graph
Bug Flags:
approval +

Details

Attachments

(6 attachments, 1 obsolete attachment)

(Assignee)

Description

9 years ago
On most Bugzillas, there's plenty of room for the visibility controls in the right column of show_bug.cgi, so they might as well go there.
(Assignee)

Comment 1

9 years ago
Okay, now that I try this on landfill I remember why we didn't do this--if you have a lot of custom fields and flags, then the right column gets really long. So what do we do about that? We could put it in the left column if there are a certain total number of flags + other stuff, but (a) that's hard to calculate and (b) UIs that move around for no reason could be confusing to users.
Summary: Move the bug visibility controls into the right column → Move the bug visibility controls somewhere better
(Assignee)

Comment 2

9 years ago
Maybe we could float them to the right of the attachments table.
(Assignee)

Comment 3

9 years ago
Created attachment 408172 [details] [diff] [review]
v1

Okay, here's what I have so far. This works nicely, except when the window gets too small. What we really need is to be able to use "display: table-cell" and so on, but that might not be supported by versions of IE that we need to support. That means that we will probably have to use tables to position the items, which means that I need to do a little bit of code moving in that file that I've wanted to do for a long time anyway.
Assignee: create-and-change → mkanat
Status: NEW → ASSIGNED
(Assignee)

Updated

9 years ago
Depends on: 524254
(Assignee)

Comment 4

9 years ago
Created attachment 408182 [details] [diff] [review]
v2

Okay, here we go, I like this! :-) This moves the visibility controls to the empty whitespace on the right of the timetracking/attachments/comments table. I have a bunch of screenshots that I am going to attach.
Attachment #408172 - Attachment is obsolete: true
Attachment #408182 - Flags: review?(LpSolit)
(Assignee)

Comment 5

9 years ago
Created attachment 408183 [details]
Screenshot: Bug In Group, Member, w/ Timetracking

This screenshot shows basically everything. If you are a member of all the groups available for the bug, and the bug is in a group, this is what you see. This screenshot includes the timetracking table.
(Assignee)

Comment 6

9 years ago
Created attachment 408184 [details]
Screenshot: Bug In Group, Member

This is the same as the above, but without the timetracking table.
(Assignee)

Comment 7

9 years ago
Created attachment 408185 [details]
Screenshot: Bug NOT in Group, Member

Here's what it looks like when the bug isn't in any groups, but you are a member of all groups.
(Assignee)

Comment 8

9 years ago
Created attachment 408186 [details]
Screenshot: Bug In Group, Non-Member

This is what it looks like when the bug is in a group but you are not a member.
(Assignee)

Comment 9

9 years ago
Created attachment 408187 [details]
Screenshot: Mandatory Group (Roles Only)

This is what it looks like when the bug is only in mandatory groups (so only the role controls are displayed)
(Assignee)

Comment 10

9 years ago
Note that the patch on this bug requires the patch on the blocker.
(Assignee)

Updated

9 years ago
Blocks: 526189

Comment 11

9 years ago
Please consider the fact that in language other than English this can look different. Already there are problems with the layout here and there.
(Assignee)

Comment 12

9 years ago
(In reply to comment #11)
> Please consider the fact that in language other than English this can look
> different. Already there are problems with the layout here and there.

  You mean in the RTL case? It would look fine there too I'd think, no?

Comment 13

9 years ago
(In reply to comment #12)
>   You mean in the RTL case? It would look fine there too I'd think, no?

Well, in other languages the strings used in the timetracking table could widen it and therefore squeeze the visibility controls column. It would be great if Bugzilla UI was developed with other languages in mind at some most used screen resolutions.
What looks good in one language can make a headache in another, as strings lenght may vary considerably. Forced shortening of translated terms wouldn't be much user friendly.

Comment 14

9 years ago
(In reply to comment #13)
> It would be great if
> Bugzilla UI was developed with other languages in mind

We have several localizers working with us (german, russian, french and japanese ones), so we clearly have other languages in mind. We even have a test installation with 9 languages installed, at https://landfill.bugzilla.org/bugzilla_l10n/

If there are problems with our UI, they will quickly let us know.

Comment 15

9 years ago
I hope 3.4 branch will be added to the landfill soon and 4.0 version will be fully localizable without special hacks (UI plus email messages). BTW: it is a pitty that this nice piece of software isn't localize-friendly in a way as phpmyadmin or squirrelmail is. Editing one .po or .php file with all strings used is a translator's heaven :). I've read in the other bugs that this was discussed, so I keep my fingers crossed.

Updated

9 years ago
Duplicate of this bug: 117481

Comment 17

9 years ago
Comment on attachment 408182 [details] [diff] [review]
v2

>=== modified file 'template/en/default/bug/edit.html.tmpl'

>-  [% IF user.in_group(Param('timetrackinggroup')) %]

>+    [% IF user.in_group(Param('timetrackinggroup')) %]

Both lines must be [% IF user.is_timetracker %] due to bug 505039 (bitrot).



>+  <div class="bz_group_visibility_section">

>+      [% IF NOT emitted_description %]
>+        [% emitted_description = 1 %]
>+        <div class="bz_group_visibility_section">
>+      [% END %]

This IF block must go away. We already display <div class="bz_group_visibility_section"> in all cases, see above. And this makes the HTML page to not validate correctly, due to this extra <div>.


r=LpSolit with these two comments fixed.
Attachment #408182 - Flags: review?(LpSolit) → review+

Comment 18

9 years ago
This will require bug 524254 to be updated and checked in first.
Flags: approval+
(Assignee)

Comment 19

9 years ago
Okay, I did all the checkin fixes.

Checking in skins/standard/show_bug.css;
/cvsroot/mozilla/webtools/bugzilla/skins/standard/show_bug.css,v  <--  show_bug.css
new revision: 1.13; previous revision: 1.12
done
Checking in template/en/default/bug/edit.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/edit.html.tmpl,v  <--  edit.html.tmpl
new revision: 1.173; previous revision: 1.172
done
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Keywords: relnote
(Assignee)

Comment 20

9 years ago
Added to the release notes in bug 547466.
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.