Closed Bug 524327 Opened 12 years ago Closed 12 years ago

[10.6] Hoefler Text css font crashes Firefox 3.5.3 on Snow Leopard

Categories

(Core :: Graphics, defect)

1.9.1 Branch
x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: sayrer, Unassigned)

References

()

Details

(Keywords: crash)

http://twitter.com/jchris/status/5135877463

I guess this page was crashing firefox when it contained the relevant CSS:

http://jchrisa.net/drl/_design/sofa/_show/post/HTML5-Storage-Continues
Severity: normal → critical
Keywords: crash
If someone running Snow Leopard - I haven't made the jump yet - could try this and get us a stack for the crash (assuming it's reproducible), I'd appreciate it.
That sounds an unlikely candidate, judging by the function signature TLWFNType1Font::TLWFNType1Font(....). That looks like it would be handling old "classic-style" LWFN printer font resources. Hoefler Text on 10.6 is packaged as a .ttc (TrueType Collection) file, I believe; in 10.5 it was .dfont. It's never been shipped in LWFN form, AFAIK.
Distilled testcase based on the HTML5 storage page in the description.  Crashes 1.9.1.x, 1.9.2 but not trunk which must be using CoreText.  Setting gfx.force_atsui_text on to true on trunk makes the problem occur on trunk also.  Does not crash on 10.5.
Component: Layout: Text → Graphics
QA Contact: layout.fonts-and-text → thebes
Summary: Hoefler Text css font crashes Firefox 3.5.3 on Snow Leopard → [10.6] Hoefler Text css font crashes Firefox 3.5.3 on Snow Leopard
Version: unspecified → 1.9.1 Branch
CoreText is doing some wacky stuff too, the text "Our goal original goal is for the spec" is rendered as "Our goal original goal is ffkor the spec".  Copying and pasting this text displays correctly.  Safari also renders the text correctly.
0  ATS ProcessSingleMorphRun  	
1  ATS ProcessMorphActionList 	
2  ATS ApplyMorphForRun 	
3  ATS ApplyMorph 	
4  ATS _eLLCLayoutText 	
5  ATS LLCLayoutText 	
6  QD  ATSULayoutGlyphs 	
7  QD  TTextLineLayout::LayoutGlyphVector 	
8  QD  TTextLineLayout::EnsureLayoutIsUpToDate 	
9  QD  TTextLineLayout::GetGlyphBounds 	
10 QD  ATSUGetGlyphBounds 	
11 XUL gfxAtsuiFontGroup::InitTextRun 	gfx/thebes/src/gfxAtsuiFonts.cpp:1539
12 XUL gfxAtsuiFontGroup::MakeTextRun 	gfx/thebes/src/gfxAtsuiFonts.cpp:781
13 XUL TextRunWordCache::MakeTextRun 	gfx/thebes/src/gfxTextRunWordCache.cpp:807
14 XUL gfxTextRunWordCache::MakeTextRun 	gfx/thebes/src/gfxTextRunWordCache.cpp:1003
15 XUL BuildTextRunsScanner::BuildTextRunForFrames 	layout/generic/nsTextFrameThebes.cpp:461
16 XUL BuildTextRunsScanner::FlushFrames 	layout/generic/nsTextFrameThebes.cpp:1230
Duplicate of this bug: 520569
Apple bug in ATSUI code. Fixed in 10.6.2.  Testcase renders fine on 3.5.x, 1.9.2 and trunk code with gfx.force_atsui_text set to true.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
(In reply to comment #5)
> CoreText is doing some wacky stuff too, the text "Our goal original goal is for
> the spec" is rendered as "Our goal original goal is ffkor the spec".  Copying
> and pasting this text displays correctly.  Safari also renders the text
> correctly.

Is there a bug on the CoreText problem, or is that also fixed in 10.6.2?
Looks like the font itself was updated in 10.6.2:

Hoefler Text; 6.1d7e1; 2009-09-21

Will test with original font to make sure ATSUI code has been fixed.
(In reply to comment #9)
> Is there a bug on the CoreText problem, or is that also fixed in 10.6.2?

Yup, trunk code on 10.6.2 renders without the problems noted in comment 5.
Hoefler Text version that shipped in initial 10.6 release:
Hoefler Text; 6.1d6e1; 2009-05-06
You need to log in before you can comment on or make changes to this bug.