Intermittent timeouts of test_bug495300.html

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: philor, Assigned: kinetik)

Tracking

({intermittent-failure})

Trunk
x86
Windows Server 2003
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

10 years ago
Looks like this has been happening for at least a couple of days, but we've been successful at just ignoring it. As far back as I was willing to look:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256368389.1256369990.22341.gz
WINNT 5.2 mozilla-central test debug mochitests-1/5 on 2009/10/24 00:13:09

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256428876.1256430589.23712.gz
WINNT 5.2 mozilla-central test debug mochitests-1/5 on 2009/10/24 17:01:16

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256430027.1256431620.2311.gz
WINNT 5.2 mozilla-central test debug mochitests-1/5 on 2009/10/24 17:20:27  

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256335904.1256337542.27589.gz
WINNT 5.2 mozilla-central test debug mochitests-1/5 on 2009/10/23 15:11:44

A successful run logs:

39685 INFO TEST-PASS | /tests/content/media/test/test_bug495145_wav.html | Playing after pause while ended works
39687 INFO Running /tests/content/media/test/test_bug495300.html...
++DOMWINDOW == 127 (0C81CE18) [serial = 1070] [outer = 06ADA218]
39688 INFO TEST-PASS | /tests/content/media/test/test_bug495300.html | Got expected 'ended' event: http://localhost:8888/tests/content/media/test/320x240.ogv
39689 INFO TEST-PASS | /tests/content/media/test/test_bug495300.html | currentTime equals duration: http://localhost:8888/tests/content/media/test/320x240.ogv
39690 INFO TEST-PASS | /tests/content/media/test/test_bug495300.html | Got expected 'ended' event: http://localhost:8888/tests/content/media/test/r11025_s16_c1.wav
39691 INFO TEST-PASS | /tests/content/media/test/test_bug495300.html | currentTime equals duration: http://localhost:8888/tests/content/media/test/r11025_s16_c1.wav
39692 INFO TEST-PASS | /tests/content/media/test/test_bug495300.html | Got expected 'ended' event: http://localhost:8888/tests/content/media/test/seek.ogv
39693 INFO TEST-PASS | /tests/content/media/test/test_bug495300.html | currentTime equals duration: http://localhost:8888/tests/content/media/test/seek.ogv
39695 INFO Running /tests/content/media/test/test_bug495319.html...

And the unsuccessful ones log:

39669 INFO TEST-PASS | /tests/content/media/test/test_bug495145_wav.html | Playing after pause while ended works
39671 INFO Running /tests/content/media/test/test_bug495300.html...
++DOMWINDOW == 129 (0E5B8E68) [serial = 1069] [outer = 06C33DD0]
39672 INFO TEST-PASS | /tests/content/media/test/test_bug495300.html | Got expected 'ended' event: http://localhost:8888/tests/content/media/test/320x240.ogv
39673 INFO TEST-PASS | /tests/content/media/test/test_bug495300.html | currentTime equals duration: http://localhost:8888/tests/content/media/test/320x240.ogv
39674 INFO TEST-PASS | /tests/content/media/test/test_bug495300.html | Got expected 'ended' event: http://localhost:8888/tests/content/media/test/r11025_s16_c1.wav
39675 INFO TEST-PASS | /tests/content/media/test/test_bug495300.html | currentTime equals duration: http://localhost:8888/tests/content/media/test/r11025_s16_c1.wav
--DOMWINDOW == 128 (0CC7BE28) [serial = 1063] [outer = 06C33DD0] [url = http://localhost:8888/tests/content/media/test/test_bug468190.html]
--DOMWINDOW == 127 (0D35DC40) [serial = 1062] [outer = 06C33DD0] [url = http://localhost:8888/tests/content/media/test/test_bug465498.html]
WARNING: NS_ENSURE_TRUE(docEvent && target) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/base/src/nsContentUtils.cpp, line 3188
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80070057: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/base/src/nsContentUtils.cpp, line 3224
WARNING: NS_ENSURE_TRUE(docEvent && target) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/base/src/nsContentUtils.cpp, line 3188
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80070057: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/base/src/nsContentUtils.cpp, line 3224
WARNING: NS_ENSURE_TRUE(docEvent && target) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/base/src/nsContentUtils.cpp, line 3188
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80070057: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/base/src/nsContentUtils.cpp, line 3224
WARNING: NS_ENSURE_TRUE(docEvent && target) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/base/src/nsContentUtils.cpp, line 3188
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80070057: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/base/src/nsContentUtils.cpp, line 3224
WARNING: NS_ENSURE_TRUE(docEvent && target) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/base/src/nsContentUtils.cpp, line 3188
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80070057: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/base/src/nsContentUtils.cpp, line 3224
WARNING: NS_ENSURE_TRUE(docEvent && target) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/base/src/nsContentUtils.cpp, line 3188
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80070057: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/content/base/src/nsContentUtils.cpp, line 3224
39676 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_bug495300.html | Test timed out.
Whiteboard: [orange]
Assignee

Comment 1

10 years ago
I rewrote this when bug 499874 landed, I'll take a look.  Is this only failing on debug WinNT machines?
Assignee: nobody → kinetik
Reporter

Comment 2

10 years ago
Well, I sort of hope it's only on debug Windows - I looked at all the unstarred orange between then and now, but I didn't look at all the starred orange to see whether someone had just starred the first of multiple failures and either failed to see another unfiled failure, or ignored it because it was too much trouble to file (both of which wouldn't be the first time).
Assignee

Comment 4

10 years ago
I reproduced this locally, and now I think this is a variant of bug 518659.  The test is written in a similar manner, so it's possible that the still in-use media elements have been GCed.

In a Firefox process where I'd run the same test multiple times in parallel, three tabs ended up with hung tests.  I couldn't find any running decoder threads when attaching to the process with a debugger.
Assignee

Comment 5

10 years ago
Yeah, with the remaining patches from bug 518659 applied, this test runs reliably hundreds of times over.
Depends on: 518659
Reporter

Comment 6

10 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256551331.1256553906.31654.gz#err1
WINNT 5.2 mozilla-central test debug mochitests-1/5 on 2009/10/26 03:02:11
Assignee

Comment 7

10 years ago
Resolved by bug 518659 landing.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED

Updated

9 years ago
Blocks: 438871
Comment hidden (Legacy TBPL/Treeherder Robot)
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.