The Alt text of the last object hovered over displays when/where it shouldn't

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: shawn.bakker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

Whenever you hover over an object with Alt text that alt text will display anytime your cursor stops moving for a second. It doesn't matter where the cursor is, it can be over whitespace or on another tab, but the last Alt text will display if you stop moving the cursor. Can be really annoying if the Alt text is long to have it popping up every time you move your mouse a little.

Reproducible: Always

Steps to Reproduce:
1. Hover over an object that has Alt text.
2. Move the mouse cursor somewhere else on the page where there shouldn't be an Alt text, can even be another tab.
3. Hold the mouse still for a second or two.
Actual Results:  
The previous Alt text will display.

Expected Results:  
Alt text should not display at all unless the cursor is over something that has Alt text.
Firefox doesn't display tooltips for alt texts as it should.
Do you mean title tags, do you have an example page ?

Comment 2

9 years ago
This is an old bug, firefox suffers when it works with tool-tips
see this https://bugzilla.mozilla.org/show_bug.cgi?id=362635#c9

but this bug is fixed on the next version as I tested it on Minefield/3.7a1pre
(Reporter)

Comment 3

9 years ago
I guess the correct term is tool-tip

I don't have an example page because it happens on every page for me. For instance if I move my mouse around on this page (gmail) when I stop moving it a tool-tip displays even if I am not over any links or images. The tool-tip that is displaying right now is from another tab that I was looking at a page in and have since closed.

I am going to attach a screencap of what I am seeing.
(Reporter)

Comment 4

9 years ago
Created attachment 408786 [details]
Screencap of tool-tip displaying where it shouldn't
I can not reproduce the issue with SM trunk and this testcase :
https://bugzilla.mozilla.org/attachment.cgi?id=248555

>I don't have an example page because it happens on every page for me
Post the URL of such an example page in such a case.. This example should be accessible without login and you should provide the information on which Element on the page the tooltip appears. Firefox doesn't display tooltips for "alt" Tags but such addons are adding such a functionality. An alternative way would be that you test without addons (http://support.mozilla.com/en-US/kb/Safe+Mode)
(Reporter)

Comment 6

9 years ago
Ok Matthias, I feel stupid now. It was an Add-On and I should have thought of that. The Add-On is called ArchiveFacebook and as soon as I disabled it I stopped having the problem. Looks like this bug can be closed.

Thanks for the help and attention.
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.