Jumbled display (unreadable) after scrolling/jumping far down in one leap on a long page

RESOLVED DUPLICATE of bug 215055

Status

()

RESOLVED DUPLICATE of bug 215055
9 years ago
9 years ago

People

(Reporter: Lena, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.9.1.3) Gecko/20090924 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.9.1.3) Gecko/20090924 Firefox/3.5.3

The test page http://lena.kiev.ua/test_bug_firefox.html (553 KB long) is a copy (text replaced with xxxxxxx for privacy) from a web-mail service displaying a long letter. If I scroll far down in one leap (by pressing the End keyboard key or by middle-clicking at the bottom of scrollbar) then text becomes unreadable, with weird visual effects (memory corruption?).

Reproducible: Always

Steps to Reproduce:
1. Start Firefox 3.5.3 in safe mode on a 800*600 screen (the bug manifests without safe mode too; window size possibly matters).
2. Open test page http://lena.kiev.ua/test_bug_firefox.html , wait until it finishes loading.
3. Press and hold the PageDown key, wait until the page scrolls to the bottom (this way the page is displayed OK).
4. Scroll with the PageUp or up-arrow key or mouse wheel a couple screens up, then down again to the bottom, remember how the bottom of the page looks.
5. Press the Home key (the top of the page displays OK).
6. Press the End key, note that the bottom of the page looks not as before, the text disappears.
7. Scroll a little up and down several times with arrow keys or mouse wheel, observe weird visual effects.



The bug apparently manifests under Windows too because another person complained that only beginning of a letter with same content is displayed on the same web-mail service.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 215055
Reporter, this bug is fixed for Firefox 3.6. You can confirm that with the beta version that is available for download now or the RC version coming very soon.
You need to log in before you can comment on or make changes to this bug.