If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When form filling, tapping "Done" should restore previous browser view

VERIFIED FIXED

Status

Fennec Graveyard
General
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: stechz, Unassigned)

Tracking

Trunk
x86
Mac OS X

Details

(Whiteboard: formfill)

(Reporter)

Description

8 years ago
The form fill helper dialog should also probably disappear on doubletap.
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
Whiteboard: formfill
Duplicate of this bug: 525348
Since Bug 525348 is duped to this now, we should explicitly make sure to restore previous zoom level as well.
It is certainly better to get back to a fewer zoom level but I'm not sure we need to restore the previous browser view, my main point is that when you fill a form till the end you want to be close to the "submit" button or any similar way to validate your entry.
(In reply to comment #2)
> Since Bug 525348 is duped to this now, we should explicitly make sure to
> restore previous zoom level as well.

You're assuming that when "Done" is pressed the user wants us to reset the zoom and scroll location. If the user presses "Next" several times we change zoom (possibly each time) and scroll. The old zoom and scroll may not be relevant anymore.
If we restore the previous zoom level we can also enter in a deeper zoom...
Maybe we can set the zoomLevel to 1.0 but keep the actual scroll
(Reporter)

Comment 6

8 years ago
Setting it to 1.0 is probably wrong since we use zoomToFit as the standard "go back to the default" setting.

One use case I'm concerned about:
1) Accidentally click a form field
2) Get zoomed in losing context
3) How do I get back to where I was before?

But come to think of it, I haven't accidentally clicked anything in a while so maybe I am getting ahead of myself.
Duplicate of this bug: 528511
I think we need to keep the behavior, for a couple of reasons.  One is that it's relatively easy, after dismissing the form assistant to return to 100% zoom by doubletapping, whereas getting to the particular zoom level created by zooming to the form can be relatively difficult.

Also, for the moment, if people think that tapping done submits the form (which it doesn't), we want to leave them zoomed in close to the form's actual buttons (of which there may be a couple).
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
tracking-fennec: ? → ---
> Also, for the moment, if people think that tapping done submits the form (which
> it doesn't), we want to leave them zoomed in close to the form's actual buttons
> (of which there may be a couple).

This is my problem with the implementation. There's a lot of times when the zoomed in version doesn't show the login button and does not show whether the page has begun loading or not because the url bar is not visible. When a user clicks on "Done", it probably means that they've indirectly clicked the submit/login button (blassey and stechz have said the same). Since it doesn't, the user usually just waits there the first time or couple of times they use it until they check if the page is loading or not.

I think this needs to be discussed more through, at the very least, some sort of community focus group (testday? all-hands? something else?).
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(In reply to comment #9)

> When a user
> clicks on "Done", it probably means that they've indirectly clicked the
> submit/login button (blassey and stechz have said the same).

Just to be sure I'm following - I think you're saying that they're tapping on the "done" button because they misunderstand it to be a stand-in for the form's submit button?

I agree that this misunderstanding is an issue, but I'm not sure it bears on the issue of whether to return to the previous zoom level.  Bug 532735 will help with this, by conveying more of a sense of "dismiss" than "submit."


> I think this needs to be discussed more through, at the very least, some sort
> of community focus group (testday? all-hands? something else?).

More people using the thing in real situations is always a good thing.  I still think that it's less destructive to leave the user where they were when they dismissed the bar (given that zooming back to 100% is easier than focusing a field again from 100% zoom), but more usage will give us a better sense.  Let's watch this as more people use it.

I would not block 1.0 on this, probably obviously given that I'm still pretty sure that we shouldn't do it. :)

Comment 11

8 years ago
1) This is the behaviour I expected (and still do).
2) It seems really weird to me being zoomed in far enough that my grandmother can see it from her grave. Personally, I don't want a shoulder surfer looking at any of this and easy to do that from a distance even catching the pw letter each time before asterisk.
3) Double-tapping is easier? Not for me - it has been pretty random and did take me some time to figure out I had to do this to zoom out "a little" - I have grown to use the volume button on the N900. However, it's not intuitive and I argue double-tapping is easier if they want to re-zoom in.
4) How about two options "Done" and "Done, Return to Regular view" (wordsmith it of course).
5) EVERY time I get zoomed in on these, it drives me nuts. Nice feature for some I'm sure. But my wife and I just don't care for it. How about an option to turn it off? Some searching and I can see anything in about:config.
6) EVERY time I am in this zoomed mode, so all links/buttons/ads/whatever are zoomed into the 'small' area, yet I have to scroll all over the place to find the submit button sometimes hitting a link on accident and having to wait a fortnight for another page to come up (x doesn't seem to react quick enough) making me do things such as submit an order all over again.
7) Most of us have grown to have more selective memory and let the UI guide us rather than memorizing things on each site. I know, you are saying, "Huh? WTH?" - I don't know exactly my bearings when zoomed that much AND never remember where submit is in relation to where I am.

I don't have statistically relevant research data, but did have my wife use and a couple friends plus a friend with an N900. No one likes how it currently works.

Good idea, but allow it to be disabled for those of us who don't want it, add an option in addition to DONE if enabled (besides relying on someone to know to doubletap - I still know people who have no clue that does anything on other devices or even know what multitouch is other than it seems their phone is posessed when something happens).

Agree, watch it more, but I think with some simple user-defineable options (prob not in about:config either - preferences pane) and another 'Done' choice (or an option what "Done" does) would actually be win:win rather than sacrificing one user's preference over another.

Comment 12

8 years ago
Sorry - "1) This is the behaviour I expected (and still do)."
That means, hitting Done returns you to previous 'zoom'. Those I've talked to also expected it to do this.
finally, this case has been handle in a more generic bug: bug 538700.

I will close to one as "resolved fixed" by bug 538700 as soon as it landed except if some people have any objections?
Depends on: 538700

Comment 14

8 years ago
i object to bugs rotting :)
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
The bug's initial report was based off the formfill bar having the "done" button. It's now replaced with a red "x", so I'm ok with verifying this as long as Ben and Madhava are ok with the result.
Looks good to Ben. verified FIXED.
Status: RESOLVED → VERIFIED
verified
You need to log in before you can comment on or make changes to this bug.