winmo emulator non-zero exit code tests intermittently fail

VERIFIED FIXED in Future

Status

Tamarin
Tools
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: Dan Schaffer, Assigned: Dan Schaffer)

Tracking

unspecified
Future
x86
Windows Vista

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
The acceptance tests where the expected exit code is non-zero fail intermittently

to reproduce run tests on winmo emulator:
mmgc/outofmemory.as
ecma3/Exceptions/exception_011_rt.as
regress/bug_515935.as
(Assignee)

Comment 1

8 years ago
Created attachment 408474 [details] [diff] [review]
patch for winmo emulator exit code fix

the failure in the acceptance tests in buildbot is due to an i/o error where the wmrunner.exe has not created the .exitcode file when the wmemulatorshell.py looks for it.  Added a retry logic to wmemulatorshell.py to look for the exitcode file for a period of time.  If not .exitcode file is found retry the test on a new emulator (the standard retry logic).  I changed the exitcode file to be per file instead of once per emulator.  I believe this will fix the intermittent failing emulator test problems.
Assignee: nobody → dschaffe
Status: NEW → ASSIGNED
Attachment #408474 - Flags: review?(brbaker)
(Assignee)

Updated

8 years ago
Target Milestone: --- → Future

Updated

8 years ago
Attachment #408474 - Flags: review?(brbaker) → review+
(Assignee)

Comment 2

8 years ago
pushed fix in 2901 : 02e352ef8d72, will let it simmer for a while before closing.
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

8 years ago
marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.