Javascript-animated SVG stops when using mouse scroll wheel

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Tristan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4) Gecko/20091006 Firefox/3.5.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4) Gecko/20091006 Firefox/3.5.4

An animated SVG, such as the animated engine at http://www.animatedengines.com/svg/test.xhtml, stops moving when scrolling down the web page using the middle mouse scroll wheel.  This breaks the user experience.  It appears that actually grabbing the side scroll bar and moving it up and down works, so the bug related to the mouse scroll wheel. By comparison, Safari seems to have no problem: the svg keeps moving while using the mouse scroll wheel.

Reproducible: Always

Steps to Reproduce:
1. Visit http://www.animatedengines.com/svg/test.xhtml
2. Scroll using the mouse scroll wheel.
Actual Results:  
Animation stops while scrolling and restarts only after the scrolling stops.

Expected Results:  
Animation should continue smoothly while scrolling

Another example site is http://vis.stanford.edu/protovis/ex/waves.html
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20091026 Minefield/3.7a1pre

This works fine for me on Windows.
Note that the example is not an SMIL animated SVG. It uses javascript.
Works fine for me using latest Firefox 3.5.x nightly on Mac:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.5pre) Gecko/20091027 Shiretoko/3.5.5pre
Summary: Animated SVG stops when using mouse scroll wheel → Javascript-animated SVG stops when using mouse scroll wheel
(Reporter)

Comment 4

8 years ago
This appears to only happen if you increase the frame rate.  What is strange, is that the problem persists if you reduce it back to 30fps.  It also persists if you close and reopen the tab or go to a different SVG animation, such as the protovis example. 

However, all these problems appears fixed for me on the latest Mac nightly:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20091027 Minefield/3.7a1pre
Ok, *if* I enable the about:config preference "general.smoothScroll", THEN I can reproduce this on OS X, at both of the URLs given in comment 0.  The image pauses (or practically pauses *almost* all the way down) while the smooth-scroll-steps execute.  I see this in the latest 1.9.1 and mozilla-central nightlies.  This happens regardless of FPS.

Without toggling general.smoothScroll, I can't reproduce this, regardless of FPS.

Tristan: do you have general.smoothScroll enabled? And does the problem go away if you disable it?
(In reply to comment #5)
> pauses (or practically pauses *almost* all the way down)
sorry -- I meant "... _slowing_ *almost* all the way down)"
(Reporter)

Comment 7

8 years ago
If I turn off smooth scrolling then things work in 3.5.  However, it does seem tied to FPS setting.  If I change the FPS setting things get much much worse. With smooth scrolling, I can make things break by scrolling wildly under the standard fps but if I change the fps I just need to scroll a little for things to lag like crazy.  This lag then sticks around across pages/tabs.

However, this all seems fixed in 1.9.3alpre.  I cannot reproduce this bug with today's nightly both with or without smooth scrolling.  So I'm happy if this bug is marked resolved.
Marking WFM based on comment 7
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.