Closed Bug 524659 Opened 10 years ago Closed 10 years ago

Fennec's use of JarMaker.py for processing an objdir jar.mn fails if the objdir is outside of topsrcdir

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(status1.9.2 beta2-fixed)

RESOLVED FIXED
mozilla1.9.2
Tracking Status
status1.9.2 --- beta2-fixed

People

(Reporter: Gavin, Assigned: Gavin)

References

Details

Attachments

(2 files)

because the l10ndirs logic asserts that srcdir.startswith(topsrc) so that the l10ndir logic works correctly. In the fennec case, srcdir is the objdir where where the dynamically generated jar.mn lives. Since we pass in src directories manually we don't need that logic, so I proposed just making it conditional rather than an assert.
Attached patch patchSplinter Review
Not sure whether the comment's right, suggestions welcome!
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #408578 - Flags: review?
Attachment #408578 - Flags: review? → review?(l10n)
Comment on attachment 408578 [details] [diff] [review]
patch

Please add another section to the makeJars docstring, something like

This logic is disabled if the jar.mn path is not inside the topsrcdir.
Attachment #408578 - Flags: review?(l10n) → review+
https://hg.mozilla.org/mozilla-central/rev/57e42052ea96
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
Comment on attachment 408578 [details] [diff] [review]
patch

Requesting approval for 1.9.2. I'd like to land those together with the two patches in bug 505713 to not fork that code, and because they're good to take.
Attachment #408578 - Flags: approval1.9.2?
Duplicate of this bug: 525697
This is a pita for Fennec developers, many of whom use objdirs outside of the srcdir
Attachment #408578 - Flags: approval1.9.2? → approval1.9.2+
http://hg.mozilla.org/releases/mozilla-1.9.2/pushloghtml?changeset=c399c316ae22, landed on 1.9.2
Target Milestone: mozilla1.9.3a1 → mozilla1.9.2
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.