"Close other tabs" only closes alternate tabs

RESOLVED FIXED in Thunderbird 3.0rc1

Status

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: pam, Assigned: sid0)

Tracking

unspecified
Thunderbird 3.0rc1
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.5pre) Gecko/20091025 Ubuntu/9.10 (karmic) Shiretoko/3.5.5pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5pre) Gecko/20091026 Shredder/3.0pre

Right click on a tab and select "Close other tabs". Not all tabs close.


Reproducible: Always

Steps to Reproduce:
1.Setting up 4 tabs labelled 1,2,3 and 4
2.Right click on tab 1 and select "close other tabs". Tabs 1 AND 3 remain.
3.Right click on tab 2 and select "close other tabs". Tabs 2 AND 4 remain.
4.Right click on tab 3 and select "close other tabs". Tabs 3 AND 2 remain.
5.Right click on tab 4 and select "close other tabs". Tabs 4 AND 2 remain.
Actual Results:  
As above

Expected Results:  
All other tabs would close, except the one originally clicked
Component: General → Toolbars and Tabs
QA Contact: general → toolbars-tabs
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5pre) Gecko/20091027 Shredder/3.0pre

I see basically the same problem in safe mode. Sometimes only one tab out of four closes.
I have set mail.tabs.closeWindowWithLastTab to false. For me first tab never closes and other tabs close a bit different from settings above, but there are definitely more tabs open than expected after closing other tabs...
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86 → All
(Assignee)

Comment 3

9 years ago
Created attachment 411163 [details] [diff] [review]
patch
Assignee: nobody → sid.bugzilla
Status: NEW → ASSIGNED
Attachment #411163 - Flags: review?(bugzilla)
(Assignee)

Comment 4

9 years ago
It's alternate because we skip a tab each time we close a tab.
Summary: "Close other tabs" only closes the rightmost tab → "Close other tabs" only closes alternate tabs
Attachment #411163 - Flags: review?(bugzilla)
Attachment #411163 - Flags: review+
Attachment #411163 - Flags: approval-thunderbird3+
Comment on attachment 411163 [details] [diff] [review]
patch

>+            for (var i = this.tabInfo.length - 1; i >= 0; i--) {

nit: let.

r+a=Standard8

Would be nice to get unit tests at some stage on this, so please set in-testsuite? if you don't have them already.
(Assignee)

Comment 6

9 years ago
http://hg.mozilla.org/comm-central/rev/81be9737934c
http://hg.mozilla.org/releases/comm-1.9.1/rev/09a2ff867204
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0rc1
You need to log in before you can comment on or make changes to this bug.