Can't receive map information from Netscape http://maps

VERIFIED FIXED

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Jaime Rodriguez, Jr., Assigned: mjudge)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+][Fix in hand], URL)

(Reporter)

Description

18 years ago
Build ID: 2000091108
Reproducible: Always

Steps:
1. Launch N6
2. Enter maps into the URL field
3. Receive the Netscape Campus "The Locator" page
4. Enter the name of the person you wish to find

Result: No information is returned to the bottom frame

Comment 1

18 years ago
Adding dogfood keyword.
Keywords: dogfood

Comment 2

18 years ago
I'm getting a "focusedWindow.location has no properties in
chrome://navigator/content/navigator.js line 119" message in the javascript
console. over to jst.
Assignee: asa → jst

Comment 3

18 years ago
This is actually a day-to-day activity for Netscaper's, and would make folks
have to use Navv 4.x, rather than N-6.... so I'll mark this as dogfood-plus.
This would not stop a N-6 ship, but getting it working will help folks use/test
N6, which in turn will help find high visibility bugs.
Summary: Can't receive map information from → Can't receive map information from Netscape http://maps
Whiteboard: [dogfood+]

Comment 4

18 years ago
what component is this?
(Reporter)

Comment 5

18 years ago
navigator
Reassigning to rods, turns out that the input field in the upper frame on maps
has an onchange handler that triggers the search, but in mozilla, if you type a
name in the input and hit enter, we don't generate an onchange event. If you
type a name and click anywhere outside the input field the search will be
triggerd. Rod, I'm not sure if this fix should go into the
nsGfxTextControlFrame2 code or into nsHTMLInputElement, either one could work I
suppose...

Cc:ing pollmann, heikki, joki and jay
Assignee: jst → rods
Component: Browser-General → HTML Form Controls
OS: Windows 98 → All
Hardware: PC → All

Comment 7

18 years ago
Reassigning to editor. I would have put the notification in 
nsHTMLInputElement.cpp, and there is a really easy spot to it but.....

When you hit return the text input appears to remember the state of the content 
and then the next time you hit return it compares the current state with that 
state. If the state has changed in between the two times you have hit return, 
then and only then is it sent.

In Nav 4.x you can type in "ABC" and hit return and the onchange will fire. Then 
you can type in DEF (so the string is now ABCDEF), now without hitting return 
backspace three times and then hit return. The onchange is not fired. 

Summary:
The OnChange is fired only if the contents of the input text has changed since 
the last time you hit return (or if it is the first time you hit return).

This is an editor thing because they will have to have someway to remember the 
state each time the return key is hit. One option is to change 
nsHTMLInputElement.cpp to generate the OnChange, but in that piece of code you 
would have to ask the input content if it had changed since the last time return 
was hit.
Assignee: rods → beppe

Comment 8

18 years ago
By the way, I'm working on fixing the animation part of The Locator
to now support Nav6, so hopefully we are close to getting The Locator to being
fully functional, in every way, with Nav6.  And I really appreciate everybody's
efforts here, as well as in past Locator-spawned Nav6 mozilla bug reports.

I figured out how to do the animation in Nav6:

     http://ledzep.red.iplanet.com/u/jay/xfer/dom6.shtml

so now I just need to migrate this code into The Locator's final DHTML.

(I'm the author/creator of The Locator, by the way  :>  )

Thanks everybody!

Comment 9

18 years ago
setting default qa
QA Contact: doronr → ckritzer

Comment 10

18 years ago
Assigning to mjudge@netscape.com, he has a fix for this already.
Whiteboard: [dogfood+] → [dogfood+][Fix in hand]

Comment 11

18 years ago
=
Assignee: beppe → mjudge

Comment 12

18 years ago
If you have a fix in hand... can we get an attached patch, and start the review
process?
(Assignee)

Comment 13

18 years ago
fixed.
Status: NEW → ASSIGNED
(Assignee)

Comment 14

18 years ago
fixed. sorry no resoultion
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago

Comment 15

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma

Comment 16

18 years ago
Verified on 2000092711 build.
Platform: WinNT

When a person name is entered, the complete information is displayed in the
bottom screen.
Status: RESOLVED → VERIFIED
mid-air collision ? / bugzilla cleanup
Reopening (current State: verified and no resolution
really reopening
* SORRY for the SPAM *
Status: VERIFIED → REOPENED
fixed
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED
verfied
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.