[facetted search] Search Form Should Revert to Blank...eventually...

RESOLVED INVALID

Status

Thunderbird
Search
--
enhancement
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: mlissner@michaeljaylissner.com, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5pre) Gecko/20091024 Ubuntu/9.04 (jaunty) Firefox/3.5.2
Build Identifier: 3.0b4pre

In TB3, there is an awesome and amazing new search tool. One lesson though from FF that has not translated over is the need for the search form to eventually go blank. This is important for two reasons that immediately come to mind:
1. Privacy - who knows what you last searched for. It can be very telling to see who or what somebody last searched for.
2. Convenience & usability - odds are that the next time you search for something, it will be different than what you searched for the previous time. Having the search form by blank at that time would be a good thing.

Reproducible: Always

Steps to Reproduce:
1. Search for something
2. Wait a while
3. Note that your search term never blanks out.



FF has this functionality via an add-on, but it seems like the kind of thing that should be in core: https://addons.mozilla.org/en-US/firefox/addon/3544#
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Search Form Should Revert to Blank...eventually... → [facetted search] Search Form Should Revert to Blank...eventually...

Comment 1

8 years ago
I think it's unclear this is needed or wanted. But version 3.1 current behavior clears the field, so closing invalid.

Note however:
* FF still hasn't implemented this
* I don't see a privacy advantage - the rest of the UI is there in all it's glory for anyone to see
* convenience for some perhaps - but 
  - i doubt there is an overwhelming majority of people who need it cleared or not cleared by default, and ...
  - removal is trivial with ctrl+A and type/delete
* bug 568521 should be a prerequisite IF this behavior is to be adopted 

but addon may be a better way to go

what do you mean by "eventually"?  you mean the text should some how time out?
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Depends on: 568521
Resolution: --- → INVALID
(Reporter)

Comment 2

8 years ago
You're right, 3.1 does go to blank immediately after searching. That's probably not optimal, because people usually want to refine their searches, but the idea for this bug was for the process to go like this:
1. User performs a search
2. Results are shown
3. User reads results, refines search, iterates, etc.
4. A few minutes later, the UI blanks the field automatically.

The advantage of this is that search refining and iteration are possible, and that minutes or hours after a search, traces of your search aren't still visible.

Imagine if you had searched for something private, found what you're looking for, then closed the search interface. You'd expect that to be enough, but in the 3.0 version you also had to clear the search field.

There's a FF extension for this, but I'm not sure why it's not the default action, since it's good for UX as well as privacy.

I suppose it is trivial to blank out the field, but remembering to may not be that easy...

All that said, invalid does make sense, since the functionality has changed...
You need to log in before you can comment on or make changes to this bug.