If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Make 2 Lightning All-Day Repeat Appointments with same name: 2nd Replaces 1st

RESOLVED WORKSFORME

Status

Calendar
General
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Andi, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Thunderbird 2.0.0.23 (20090812), Lightning 0.9

I made a repeating appointment called "Rubbish: Cans" for the 1st Saturday of each month between two dates, then made a second for the 3rd Saturday of each month with the same name.

Although the 1st appointment was correctly scheduled after I set it, and the 2nd was correctly scheduled after I set that; after setting the 2nd appointmnet, the 1st disappeared.  (See steps below)

Reproducible: Always

Steps to Reproduce:
These are the steps followed, which produced the same result for Mozilla Live Chat support:
1) Select date 2009-11-07
2) Double click in Calendar "All-Day" section and see "New Event" dialogue
3) Use as title: "Rubbish: cans"
4) ("All-day event" is selected)
5) Repeat: Custom: 1st Saturday of each month until 2010-01-17
6) Click "Ok", "Save and Close"
7) Check 1st Saturday of November-2009, December-2009, January-2010: appointment fine.
8) Select date 2009-11-21
9) Repeat steps 2-6, except this time for 3rd Saturday of each month until 2010-01-17
10) Check 3rd Saturday of November-2009, December-2009, January-2010: appointment fine.
11) Check 1st Saturday of November-2009, December-2009, January-2010: appointments have disappeared.
Actual Results:  
Step 11 is the problem: the 2nd appointment replaced the first.

Expected Results:  
I should have ended up with 2 repeat appointments with the same name, covering the 1st and 3rd Saturdays of each month between the two dates set.

Comment 1

8 years ago
I cannot reproduce your issue using current test build of Lightning 1.0pre (20091029) with Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5pre) Gecko/20091029 Shredder/3.0pre.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.