Intermittent failure in test_smilGetStartTime.xhtml

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: philor, Assigned: birtles)

Tracking

({intermittent-failure})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Could be a one-off, but:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256648611.1256649429.21103.gz
Linux mozilla-central test mochitests-1/5 on 2009/10/27 06:03:31  

[[[
44395 INFO Running /tests/content/smil/test/test_smilGetStartTime.xhtml...
44396 INFO TEST-PASS | /tests/content/smil/test/test_smilGetStartTime.xhtml | Unexpected exception code from getStartTime.
44397 INFO TEST-PASS | /tests/content/smil/test/test_smilGetStartTime.xhtml | No exception thrown for indefinite start time.
44398 INFO TEST-PASS | /tests/content/smil/test/test_smilGetStartTime.xhtml | Unexpected start time with begin=1s
44399 ERROR TEST-UNEXPECTED-FAIL | /tests/content/smil/test/test_smilGetStartTime.xhtml | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - uncaught exception: [Exception... "An attempt was made to use an object that is not, or is no longer, usable"  code: "11" nsresult: "0x8053000b (NS_ERROR_DOM_INVALID_STATE_ERR)"  location: "http://localhost:8888/tests/content/smil/test/test_smilGetStartTime.xhtml Line: 49"] at :0
]]]
(Reporter)

Updated

10 years ago
Whiteboard: [orange]
Weird... so it looks like the exception fired somewhere after line 43 and before (or on) line 49 of the test:

43   is(anim.getStartTime(), 1, "Unexpected start time with begin=1s");
44 
45   // We have to be careful here when choosing a negative time that we choose
46   // a time that will create an interval that reaches past t=0 as SMIL has
47   // special rules for throwing away intervals that end before t=0
48   anim.setAttribute("begin", "-0.5s");
49   is(anim.getStartTime(), -0.5, "Unexpected start time with begin=-0.5s");
http://mxr.mozilla.org/mozilla-central/source/content/smil/test/test_smilGetStartTime.xhtml
(Assignee)

Comment 2

10 years ago
getStartTime throws exceptions since bug 521705 (as per SVG 1.1 SE). But that change landed 2 weeks ago so it's odd that it shouldn't have failed until now.

Anyway, I think the problem is just that we're not pausing animations in that test.

So sometimes (when the server is a bit bogged down) we're actually sampling after the active duration, i.e. in the postactive state, which will cause an exception to throw (again, as per SVG 1.1 SE behaviour).

If that's the case, we really should just pause animations at the start of the test.

Unfortunately I can't check in from this computer. I can do it later, but if someone else agrees that that's the problem then please go ahead and patch it.
(Assignee)

Comment 3

10 years ago
I think this should fix it.
Assignee: nobody → birtles
Status: NEW → ASSIGNED
Looks good to me.
(Assignee)

Comment 7

10 years ago
:) Thanks for picking that up. Not sure what happened there. I'll try again soon.
(Assignee)

Comment 9

10 years ago
Ok, since a similar fix seems to have been successful for bug 522878 and this has been in the tree for two weeks I'm pretty confident it's fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

9 years ago
Blocks: 438871
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.