Closed Bug 524934 Opened 10 years ago Closed 4 years ago

Identity settings dialog is too small

Categories

(MailNews Core :: Account Manager, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 45.0

People

(Reporter: chtitux, Assigned: aceman)

References

()

Details

Attachments

(4 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

The dialog of Identity settings is not wide enough : I can't see the text at the right. See screenshot http://chtitux.org/vrac/param%20ident%20tb3-b4.png

Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird 3b4
2. Open the Identity settings dialog
3. It's there
Actual Results:  
The dialog is too small


I use TB3b4 with French language.
Whiteboard: dupeme
The only bug that comes close to this one is bug 522208. Wayne does this bug rings a bell ?
  Théophile does  bug 522208 look the same?

it does to me, but you're in a better position to say, as I don't normally see these things.
No, it does not.

My Account Configuration is ok (see http://chtitux.org/vrac/param%20ident%20tb3-b4%2002.png ).

The Identity settings dialog is the only one too small.
Duplicate of this bug: 526225
Whiteboard: dupeme
Same in german version.
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.5) Gecko/20091116 Shredder/3.0.1pre
(In reply to comment #5)
> Created an attachment (id=412728) [details]
> Identity settings dialog
> 
> Same in german version.
> Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.5) Gecko/20091116
> Shredder/3.0.1pre

works now for me with 3.0.1
Théophile is it better for you too ?
Attached image Dialog box too small
I've still this display error. (with Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.1.10) Gecko/20100512 Lightning/1.0b1 Thunderbird/3.0.5 )
Duplicate of this bug: 582274
Théophile do you see this also with latest TB 3.1.x?
Théophile ??
Component: Mail Window Front End → Account Manager
QA Contact: front-end → account-manager
Whiteboard: [dupeme?]
Yes, the box is still too small with TB 3.1.8
Duplicate of this bug: 651025
Is this still happening in TB14?
I tried to resize the account settings window very small and it seems to wrap correctly until much smaller size than the identity window. Maybe it was fixed since TB3.1.

There is nevertheless one inconsistency. The main account settings window can be resized thus the default identity can be stretched out as needed. But when the identity edit window is opened for any other identity, it is not resizable and has a fixed size.

I offer 3 solutions:
1. the identity edit window should be initialized with the default width being the same as the default account settings pane. Currently it is set to 67ch, while it should be 105ch (account settings) - 31ch (account tree pane) = about 74ch.
2. we could make the identity edit window resizable.
3. we could init the identity edit window with the same size as the right account settings pane currently has.
Bwinton?

Also I do not like the fact, that the XUL for the default identity (in am-main.xul) is not shared with the XUL in am-identity-edit.xul but is duplicated. But I am not sure I can implement an overlay for that. Maybe there is a reason.
Assignee: nobody → acelists
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [dupeme?]
I have determined that for option 1, the width of the identity edit window must be 75ch to match the default account settings pane width. The point of this is that when a localizer tunes the strings (if needed) to fit in one of the default sized dialogs, it will fit also in the other one automatically.
That patch for that would be trivial.
Any opinions?

http://mxr.mozilla.org/comm-central/search?string=identityDialog.style&find=&findi=&filter=^[^\0]*%24&hitlimit=&tree=comm-central
Product: Thunderbird → MailNews Core
Version: unspecified → 1.9.1 Branch
(In reply to :aceman from comment #14)
> Also I do not like the fact, that the XUL for the default identity (in
> am-main.xul) is not shared with the XUL in am-identity-edit.xul but is
> duplicated. But I am not sure I can implement an overlay for that. Maybe
> there is a reason.
I'm not aware of any reason, but someone else might. Out of scope of this bug anyway.

(In reply to :aceman from comment #15)
> I have determined that for option 1, the width of the identity edit window
> must be 75ch to match the default account settings pane width. The point of
> this is that when a localizer tunes the strings (if needed) to fit in one of
> the default sized dialogs, it will fit also in the other one automatically.
> That patch for that would be trivial.
> Any opinions?
I agree with that 75ch sounds better, see what it looks like.
OS: Windows 7 → All
Hardware: x86_64 → All
Version: 1.9.1 Branch → Trunk
Attached patch patch (obsolete) — Splinter Review
Try this with a small AM window and a big one. I am not sure if we want to set the min-width.
Attachment #656183 - Flags: ui-review?(bwinton)
Attachment #656183 - Flags: review?(iann_bugzilla)
Status: NEW → ASSIGNED
Comment on attachment 656183 [details] [diff] [review]
patch

Just wondering if there was an easier way of passing the width information.
Attachment #656183 - Flags: superreview?(neil)
Attachment #656183 - Flags: review?(iann_bugzilla)
Attachment #656183 - Flags: review+
Comment on attachment 656183 [details] [diff] [review]
patch

I can't reproduce this bug at all; if I artificially lengthen the text of the labels and controls then they either wrap (which is nice) or the dialog simply gets wider.
Attachment #656183 - Flags: superreview?(neil) → superreview-
Neil, that is true, see comment 14. The texts wrap correctly today. But the patch wants to make the standalone identity editor to be the same width as the one embedded in the main AM dialog. So as to make the wrapping identical (for consistency/ugliness reasons).
Comment on attachment 656183 [details] [diff] [review]
patch

>+++ b/mail/locales/en-US/chrome/messenger/am-identity-edit.dtd
>@@ -1,11 +1,14 @@
>-<!ENTITY identityDialog.style "width: 67ch;">
>+<!-- LOCALIZATION NOTE (identityDialog.style): This value should be roughly
>+     equal to the value of accountManager.size entity minus the value
>+     of accountTree.width entity. -->
>+<!ENTITY identityDialog.style "min-width: 75ch;">

Since you're changing this, do we need to give it a new name?

>+++ b/mailnews/base/prefs/content/am-identity-edit.js
>@@ -7,16 +7,24 @@ var gIdentity = null;  // the identity w
>+  // Make the dialog the same width as the main Account manager page
>+  // so that the identity/copies & folders are the same width as
>+  // the user set them by resizing the AM dialog.
>+  document.getElementById("identityTabsPanels").style.width =
>+    Services.wm.getMostRecentWindow("mailnews:accountmanager")
>+    .document.getElementById("contentFrame").contentDocument
>+    .getElementsByTagName("page")[0].clientWidth + "px";

Ugh, that looks kinda ugly.  But that doesn't really affect the ui-review.  ;)

This feels better.  I think we want to make it resizable, too, which might lead to some strange interactions if we don't save the previous width, but for now, this seems better than it was previously.  ui-r=me.

Thanks,
Blake.
Attachment #656183 - Flags: ui-review?(bwinton) → ui-review+
Neil, can you reproduce now?
Well, what to do here?
Comment on attachment 656183 [details] [diff] [review]
patch

This is stalled here for too long. Can I get some new ideas how to move this or what reviews are needed yet?
Attachment #656183 - Flags: review?(mkmelin+mozilla)
Comment on attachment 656183 [details] [diff] [review]
patch

Review of attachment 656183 [details] [diff] [review]:
-----------------------------------------------------------------

I think min-width: 75ch is better yes, but I don't think setting the width from the accountmanager width is necessary. (easy enough for the user to make that larger too, if needed)
Attachment #656183 - Flags: review?(mkmelin+mozilla) → feedback+
Comment on attachment 656183 [details] [diff] [review]
patch

Magnus, the point of this bug is that while it is easy for the user to resize it, he may not think about it. He just sees that the dialog is differently sized and ugly. So he files this bug. See comment 20. He may tune (if translators didn't do a good job setting the identityDialog.style) the account manager window so that the default identity fields look fine. Why should he do the same again for the standalone identity dialog? If we can automate it then why not.
Attachment #656183 - Flags: review?(neil)
Attachment #656183 - Flags: review?(mkmelin+mozilla)
Comment on attachment 656183 [details] [diff] [review]
patch

Not going to make the dialog resizable then?

>-<!ENTITY identityDialog.style "width: 67ch;">
>+<!-- LOCALIZATION NOTE (identityDialog.style): This value should be roughly
>+     equal to the value of accountManager.size entity minus the value
>+     of accountTree.width entity. -->
>+<!ENTITY identityDialog.style "min-width: 75ch;">
Not sure what the point of changing this is; if you're going to set a width anyway, you might as well remove it.

>+  // Make the dialog the same width as the main Account manager page
>+  // so that the identity/copies & folders are the same width as
>+  // the user set them by resizing the AM dialog.
>+  document.getElementById("identityTabsPanels").style.width =
>+    Services.wm.getMostRecentWindow("mailnews:accountmanager")
>+    .document.getElementById("contentFrame").contentDocument
>+    .getElementsByTagName("page")[0].clientWidth + "px";
Not sure why you're setting the panels to the width of the page; the main settings has a groupbox in the account manager which doesn't appear here but the other settings tabs keep their groupboxes which would make them the wrong width here.
I would probably use window.opener.opener to locate the account manager, but it's probably not important.
Rather than grovelling for the width of the page element, you could just use [am].contentFrame.innerWidth which is the same value.
(In reply to aceman from comment #22)
> Neil, can you reproduce now?

I notice that the dialog actually opens 14px wider than the width style specifies, so that something else is actually enforcing a minimum width. (We still want to suggest a width otherwise the description in the security tab will try to avoid wrapping on to a second line.)
(In reply to :aceman from comment #26)
> Comment on attachment 656183 [details] [diff] [review]
> patch
> 
> Magnus, the point of this bug is that while it is easy for the user to
> resize it, he may not think about it. He just sees that the dialog is
> differently sized and ugly.

Well the summary is "identity settings dialog is too small" ;)
I just didn't think it looked very good if AM is maximized -> the identity dialog looks stretched. I don't have a very strong opinion about it though.
Comment on attachment 656183 [details] [diff] [review]
patch

Review of attachment 656183 [details] [diff] [review]:
-----------------------------------------------------------------

Well, can we avoid it for maximized mode (check sizemode I belive).
Attachment #656183 - Flags: review?(mkmelin+mozilla)
Attached patch patch v2Splinter Review
Added Neil's improvement and no resizing if AM is not in sizemode=normal.
Attachment #656183 - Attachment is obsolete: true
Attachment #656183 - Flags: review?(neil)
Attachment #8691067 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8691067 [details] [diff] [review]
patch v2

Review of attachment 8691067 [details] [diff] [review]:
-----------------------------------------------------------------

Seems to work. r=mkmelin
On a side note: Still a problem with the height on 800x600 (bug 729027)
Attachment #8691067 - Flags: review?(mkmelin+mozilla) → review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/2eb5bc6198ce
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 45.0
You need to log in before you can comment on or make changes to this bug.