Jpeg images with embedded sRGB profiles not rendering (255,255,255) correctly

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
9 years ago
7 years ago

People

(Reporter: image.plus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4

sRGB images containing pure white (255,255,255) are not rendered as pure white.  Other users have confirmed this but see slightly different values. I see (253, 253, 253)

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.tonymayimages.com (home page or portfolio pages)
2. View home page image or portfolio images with white background within image
3. Use Digital Color Meter to measure displayed values
4. Confirm actual RGB values in JPEG by saving image and opening in colour managed image editing application (Photoshop)
Actual Results:  
255,255,255 rendered to different values (253,253, 253 on my system)

Expected Results:  
255,255,255

I have raised this on the Apple colorsync forum and other users have confirmed. See extract of another post below :
-----------------
I can confirm tihs issue. IMO someone should report this bug to <http://bugzilla.mozilla.org>.

With Firefox 3.5.3 / OS 10.5.8
and following about:config settings:

gfx.color_management.display_profile [empty]
gfx.color_management.mode 1
gfx.color_management.rendering_intent 0

I get 255 254 255 in the JPEG and 254 254 254 in the white page background (outside the image).

With the default setting "gfx.color_management.mode 2"
(i.e. color management enable for tagged graphics only)
the background becomes 255 255 255
and the JPG white is still 255 254 255

(see <http://kb.mozillazine.org/Gfx.color_management.enabled>)

With Firefox 3.0.14, I get 255 255 255 for both the image white and the backgroud with "gfx.color_management.enabled false" (default) as well as with "gfx.color_management.enabled true"

I use an eye-one Match 3 matrix profile, whitepoint XYZ 0.964 1.000 0.825 for my MacBook Pro 15" / Intel Core 2 Duo 2.2 GHz

BTW: if Firefox 3.5.3 an Firefox 3.0.14 are used from the same user accout, Firefox 3.5.3 affects the color management settings of Firefox 3.0.14: every time I launch Firefox 3.5.3, the "gfx.color_management.enabled" setting for Firefox 3.0 gets reset to false (i.e. the default value in 3.0)

Another issue: when I open
<http://digitalproof.info/colorsync-users/white-sRGB.jpg> in FF 3.0.15, with gfx.color_management.enabled true, I get 238 254 255, i.e. sky blue instead of white (looks like wrongly converted absolute colorimetric from D65 to D50). I'm pretty sure this bug wasn't there before I installed FF 3.5.

And yet another FF related colormanagement issue:
Firefox 3.5 is apparently no longer able to auto detect the monitor profile in Snow Leopard -- see:
<https://bugzilla.mozilla.org/show_bug.cgi?id=514932>
Component: General → GFX: Color Management
Product: Firefox → Core
QA Contact: general → color-management
Images tagged as sRGB will be converted to your display profile which can cause 255,255,255 to become a different color. http://hacks.mozilla.org/2009/06/color-correction/ has some more information on this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.