Electrolysis should build and run on gcc 4.2

RESOLVED FIXED

Status

Firefox Build System
General
RESOLVED FIXED
9 years ago
3 months ago

People

(Reporter: cjones, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

Probably want to test with FC8 and maybe Ubuntu 8.04, at least.

Comment 1

9 years ago
Run, yes. Build, I don't care quite so much. Do we know what's not building correctly? Is it something we can configure test to at least error out early instead of producing weird results halfway through a build, or even just not working quite right?
Component: IPC → Build Config
QA Contact: ipc → build-config
I think Mozilla developers are going to be annoyed if the e10s merge requires them to upgrade their linux distros.

Comment 3

9 years ago
Let's figure out exactly what the problem is. Smaug was using -ggdb -feliminate-unused-debug-symbols and most of his problems went away when he stopped using those, right? It's not clear to me that we actually have a problem yet, or what its scope is.

Comment 4

9 years ago
This doesn't block landing in m-c, though it may block enabling the pref by default.
Blocks: 478976
No longer blocks: 523094
(In reply to comment #4)
> This doesn't block landing in m-c, though it may block enabling the pref by
> default.

Since I don't think we want to land on m-c with maemo-fenntrolysis disabled, I think this should block.

Updated

9 years ago
No longer blocks: 523094

Comment 6

9 years ago
The particular issue in bug 525677 sure does, since it turns the tinderbox red! But I still don't think this bug is well-specified enough to block anything.
According to [1], our scratchbox uses gcc 4.2.1.  If that's true, then fixing bug 525677 isn't going to turn the tree green, because we should fail to link any binaries.  I can confirm that that's true for Ubuntu 8.04 / gcc 4.2.4 on x86.

[1] http://maemo.org/development/sdks/maemo_5_beta_2_sdk_installation/
Summary: Electrolysis should build and run on older linux distros / gccs → Electrolysis should build and run on gcc 4.2

Comment 8

9 years ago
It built fine until .asyncDrawXULElement landed. I don't think anyone has actually tested those binaries to see if they run.
Created attachment 410083 [details] [diff] [review]
build fixes

|explicit| copy ctors have different semantics in gcc 4.2, go to the lowest common denominator
Comment on attachment 410083 [details] [diff] [review]
build fixes

Thought I had these in different patches.  Anyways, the other fix was avoiding the typeinfo visibility bug, by ahem, hackefarious purposes.  I'm not really sure what the best "real" fix is ... configure.in test?
Attachment #410083 - Attachment description: IPDL fix → build fixes
We should be golden on 4.2 now, closing.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

7 years ago
Attachment #410083 - Attachment is obsolete: true

Updated

3 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.