Closed Bug 525019 Opened 13 years ago Closed 13 years ago

Updates to Mozilla.com Customization Page for non Firefox/3.6 users

Categories

(www.mozilla.org :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: tshahian, Assigned: mozwebqa)

References

()

Details

Attachments

(2 files)

Per Bug 523778, the Customization Page will show a dynamic mockup to showcase Personas - as opposed to using an iframe pointed at Getpersonas.com.  I'm filing a separate bug to track this functionality for the non Firefox/3.6 version of the page.
OS: Mac OS X → All
Hardware: x86 → All
Depends on: 523454
This page is basically setup now. It is missing URLs for most links. Should we just search AMO for the links, or is there a list we can work off?
(In reply to comment #1)
> This page is basically setup now. It is missing URLs for most links. Should we
> just search AMO for the links, or is there a list we can work off?

Tara, can you give Steven the links?
Hey Steven, the links for the 6 collections are below.  The links for the individual add-ons, would require an additional search on the list of add-ons under these collections.  Hope that helps.

Traveler's Pack:
https://addons.mozilla.org/collection/travel

Reference Desk:
https://addons.mozilla.org/collection/reference

Sports Fanatic:
https://addons.mozilla.org/collection/sport

Online Shopping:
https://addons.mozilla.org/collection/onlineshopping

Social Circuit:
https://addons.mozilla.org/collection/social

Web Development:
https://addons.mozilla.org/collection/webdeveloper
Assignee: steven → stephen
The link for Better Gmail 2 that Tara couldn't find in the Social Circuit collection is here:

https://addons.mozilla.org/en-US/firefox/addon/6076?collection_uuid=501c580d%26%2345%3B5bc5%26%2345%3B16af%26%2345%3B048d%26%2345%3B14ec084197de

Also, as a request from the AMO team to better track the success of this, can we please add &src=fxcustomization to every link?

Thanks!
Thanks Fligtar!  Couldn't find the darn thing.
Tara, John, Justin,

Links have been updated and committed.
Is this page ready to go QA then?
It should be.  Except that the Personas piece still doesn't have the live preview function.  Ryan? Steven? Is there something blocking you guys from implementing that?
Or, actually.  I just realized I'm back on 3.5, not the beta.  So that's probably why it's not working.  Right? :)
(In reply to comment #15)
> Or, actually.  I just realized I'm back on 3.5, not the beta.  So that's
> probably why it's not working.  Right? :)

Actually, I'm on 3.6b1 and I'm not seeing the rollover either.
The iframe src needs to point to production (getpersonas.com/en-US/external/mozilla)

Forgot to update the bug, sorry.
Thanks Ryan.  Can you please also update the thumbnails with the correct designs?
In order, from left to right, they are:

1. Japanese Tattoo - http://www.getpersonas.com/en-US/persona/7610
2. Endless Possibilities - http://www.getpersonas.com/en-US/persona/30987
3. Retro Notes - http://www.getpersonas.com/en-US/persona/32757
4. Harry Potter - http://www.getpersonas.com/en-US/persona/35081
5. Bob Marley - http://www.getpersonas.com/en-US/persona/44136
6. Sunset Over Water - http://www.getpersonas.com/en-US/persona/64769

I also have a screenshot attached.
(In reply to comment #18)
> Thanks Ryan.  Can you please also update the thumbnails with the correct
> designs?

Done!
(In reply to comment #17)
> The iframe src needs to point to production
> (getpersonas.com/en-US/external/mozilla)

Done in r55183.
The non-3.6-user javascript fallback preview work is underway on our end.
Blocks: 523778
Hey guys.  When I scroll the white space around the Personas piece.. it does a live preview of Sean's nifty animated clouds.  It acts a little weird actually.  Not sure if it's cause you're hacking on it now, or what.  But, sharing it anyway.
Persona thumbnails have been committed for what will be seen in any browser but Firefox 3.6
Is this bug considered done and ready for QA?
I don't think it is.  Unless I'm missing something.  When looking at the staged site, all 5 mock-ups are displaying vertically down the page, when they shouldn't be.  Screen-shot attached. Steven?
We were still finishing up the JS - committed it in r55382. I haven't had a chance to do any browser testing with it or anything yet though.

The intended behaviour is: 3.6 users will see the iframe persona previews. All other users (fx3.5, IE, etc) will see the just-committed Javascript-hover version.
Kicking this one over to QA - thanks all!
Assignee: stephen → mozwebqa
[1] "Web Developer Toolbar

The Web Developer extensions adds" -- "extensions" should just be the singular "extension"
[2] Page fails doctype validation spectacularly -- not sure if that's fixable
[3] "Scroll over the samples below for a quick live preview (or click on one to add it to your browser)." -- should the terminology be "hover over" or "roll over," as on http://www-3.6.stage.mozilla.com/en-US/firefox/3.6/firstrun/ (we should be consistent).
(In reply to comment #30)
> [3] "Scroll over the samples below for a quick live preview (or click on one to
> add it to your browser)." -- should the terminology be "hover over" or "roll
> over," as on http://www-3.6.stage.mozilla.com/en-US/firefox/3.6/firstrun/ (we
> should be consistent).
Great catch. Let's replace that text with the following:

"Personas are easy-to-install themes that help you personalize the look of your Firefox." 

Then, in place of the "Try these on!" text let's use "Roll over to try, click to apply" like we do on First Run.

Lastly, let's update the "choose from the gallery" link to read:
"See all 30,000+"
The wording changes from comment #30 and #31 along with most of the validation fixes are done in 55487.

I have to check with one of our developers to fix the last few validation issues.
The remaining validation issues have been fixed in r55670.
Site looks good to me; Vishal can do a final pass and comment.
Hey guys. How's this coming along?  I dropped the link to the staged site into Safari, and I'm still seeing the browser mockups all displayed vertically down the page.  I need to get this page finished to hand off to L10n.  Is there anything I can do to help here?  Thank you.
(In reply to comment #35)
> Hey guys. How's this coming along?  I dropped the link to the staged site into
> Safari, and I'm still seeing the browser mockups all displayed vertically down
> the page.  I need to get this page finished to hand off to L10n.  Is there
> anything I can do to help here?  Thank you.

Tara, I'm not seeing this issue in Safari. Are you sure you've got the latest JS/CSS loading?
(In reply to comment #36)
> (In reply to comment #35)
> > Hey guys. How's this coming along?  I dropped the link to the staged site into
> > Safari, and I'm still seeing the browser mockups all displayed vertically down
> > the page.  I need to get this page finished to hand off to L10n.  Is there
> > anything I can do to help here?  Thank you.
> 
> Tara, I'm not seeing this issue in Safari. Are you sure you've got the latest
> JS/CSS loading?

I just checked in my Safari and it looks good to me. Can we get a quick QA check to double-confirm? If it works for you guys then I'm ok with resolving this bug.
One more nit - I should have caught this earlier, but let's change the subhead to "Personas: Your Firefox, Your Style"

Thanks!
I just checked again using the same link and it seems to be working now.  
Hovering over the "endless possibilities" persona, and the nature one, gives me a white title-bar when it should be black.  Can we fix that, please?

Also, the text that says "click to apply" and the "30,000+ more" should be re-aligned in the same way as the Get Personal pages.  With the "30,000+" left aligned below the thumbnails, and the "click to apply" adjusted so it doesn't appear to be floating.
(In reply to comment #38)
> One more nit - I should have caught this earlier, but let's change the subhead
> to "Personas: Your Firefox, Your Style"

Done in r56001.
The layout of the Roll-over instructions/arrow and "View all 30,000+" link should be better as of r56003.
(In reply to comment #39)
> I just checked again using the same link and it seems to be working now.  
> Hovering over the "endless possibilities" persona, and the nature one, gives me
> a white title-bar when it should be black.  Can we fix that, please?

I actually see the white title bar on those personas in Beta 2.
(In reply to comment #42)
> (In reply to comment #39)
> > I just checked again using the same link and it seems to be working now.  
> > Hovering over the "endless possibilities" persona, and the nature one, gives me
> > a white title-bar when it should be black.  Can we fix that, please?
> 
> I actually see the white title bar on those personas in Beta 2.

Is this a problem on the personas side? What's the best way to fix?
(In reply to comment #43)
> Is this a problem on the personas side? What's the best way to fix?

I think this is the indented behaviour. Personas can set an Accent Color which applies to the title bar in Mac OS X. In the case of these personas, it must be set to white.
(In reply to comment #44)
> I think this is the indented behaviour. Personas can set an Accent Color which
> applies to the title bar in Mac OS X. In the case of these personas, it must be
> set to white.

Correct, this is the persona's settings, which we can't edit.
(In reply to comment #45)
> (In reply to comment #44)
> > I think this is the indented behaviour. Personas can set an Accent Color which
> > applies to the title bar in Mac OS X. In the case of these personas, it must be
> > set to white.
> 
> Correct, this is the persona's settings, which we can't edit.

Got it, thanks guys. In that case, can we resolve this one?
re: comment 46: please do resolve it; I think it's ready to go.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
verified fixed on http://www-3.6.stage.mozilla.com/en-US/firefox/customize/
in IE 7, IE 6, Firefox 3.5, Google Chrome, Opera 9.6
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.