Timestamp in history search window is one hour off (one hour earlier than actual time page was visited

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: Jim Tuttle, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729)

Open up the History window ("History -> Show All History" in my browser).  Open up the "Today" section, and look at the time of any site visited.  It's one hour earlier that the actual (local) time of the visit.

At a guess, this is in intermittent problem that only exists while we're in this new extended Daylight Savings Time.

For example, it's around 5:30pm EDT right now.  If we were on the "old" U.S. Daylight Savings Time schedule, we would be off Daylight Savings Time, and the time would be 4:30pm EST.  And, the History window is showing 4:30pm as the time of the last page opened (this site, Bugzilla).

Reproducible: Always

Steps to Reproduce:
See the Details.  It's pretty easy to reproduce, at least for ne,
Actual Results:  
History times are one hour earlier than they should be.

Expected Results:  
History times should match actual local times, including Daylight Savings Time adjustments.
i changed to DST recently (europe) and my times are correct

what's your timezone?
(Reporter)

Comment 2

8 years ago
Sorry I wasn't explicit about my timezone.  I'm in the U.S. Eastern timezone.

I did say that it was "around 5:30pm EDT right now" as I started entering the bug, which translates to 2:30pm (or 14:30) PDT.  Looks like it took me 14 minutes to enter the bug (14:44 PDT is shown above), so I'm a slower typer than I thought!  :-)

I confirmed this on another PC of mine too.
hm, yesterday i got a confirm that in PDT there are no problems, and in Europee there are no problems. Does your timezone have DST differences regarding PDT?
I'll try to set some machine to your timezone and see what happens.
(Reporter)

Comment 4

8 years ago
No, the Eastern timezone works like the Pacific one, meaning we shift on the same days.

I just checked this on my Mac's Firefox (same timezone, different OS), and the time in the History window is correct there.  Could be a Windows-only issue?
it's possible, but you should also check the settings on your windows machines, did you flag the "automatic DST" option?
(Reporter)

Comment 6

8 years ago
Yes, that option is set.

To test out my original theory, I closed FF, set the date on the PC forward 4 days (well past the end of DST), and re-opened FF.  Timestamps in the History window now show the correct time.

Going back to Sept (when DST is in effect using the "old" and the new rules), timestamps are correct.

Restoring the date to the proper date (w/ DST in effect according to the new rules only) returns timestamps to an hour off.

It's definitely related to this window caused by the change in DST rules.
can you eval this in the Error Console?
var dateObj = new Date();
dateObj.getTimezoneOffset();

this should return the number of minutes of difference from GMT. is the result correct?
(Reporter)

Comment 8

8 years ago
Created attachment 409450 [details]
Date/Time Control Panel
(Reporter)

Comment 9

8 years ago
The JS above didn't actually return/print anything.  I added an alert() around the last line and got 300.  300 minutes = 5 hours, which is correct.  I attached the Date/Time Control Panel to show the timezone.
i tried changing to your timezone in Vista and XP with both today's date and on 28 Oct. I visited a page, both times were reported correctly.
Are all Windows updates installed on that machine?
(Reporter)

Comment 11

8 years ago
I just double-checked:  XP SP3.  The only updates missing are a couple .NET updates and a couple new security updates (which I'll apply now).

That said, it seems I'm alone w/ this problem, so I'll chalk it up to something "odd" with the way I've configured my PCs (or my IT group has).  If you want to mark it "can't reproduce" or some such, I'm OK with that.  I really appreciate you trying!  :-)
sorry, i can't fix something that i can't reproduce.
I'll leave this open for now, in case someone can reproduce and provide a common pattern.
Does this still happen with Firefox 3.6.13 or later or Firefox 4?
Whiteboard: [CLOSEME 2011-1-30]
Version: unspecified → 3.5 Branch
(Reporter)

Comment 14

7 years ago
Created attachment 502471 [details]
History screenshot

Example of this problem occurring - note the system time and the time of the recently accessed pages.
(Reporter)

Comment 15

7 years ago
Yes, but it only happens during the narrow time-window in the Spring and Fall when we are in DST, but where we were NOT in DST a few years ago.  It seems related to the new DST rules.

Note, I have an environment variable called "TZ" defined, with a value of "EST5EDT".  This variable is required for using tools like RCS, but could change the behavior of how an app interprets time, if it's using that variable.

If you look in the screenshot provided, Windows shows the correct time (regardless of the TZ variable), but Firefox shows the time as 1-hour off.
(Reporter)

Comment 16

7 years ago
Looks like Microsoft is aware of a similar issue(http://support.microsoft.com/kb/932590).  But, their solution doesn't apply to Windows 7 and I can see the problem there.  Also, I have that patch on my XP system, and I still have the problem there.

Can someone adjust their date to Nov. 1 2010, set TZ=EST5EDT, and confirm the problem?

Updated

7 years ago
Whiteboard: [CLOSEME 2011-1-30]
Version: 3.5 Branch → 3.6 Branch

Comment 17

5 years ago
I think it's not a Mozilla problem, but a Microsoft problem. In Windows XP, even when I used Outlook Express, e-mails written in DST looked like written one hour later when seen out of DST and e-mails written out of DST looked like written one hour earlier when seen in DST. This shocking (if you don't know the operating system issue) fact applies to all files, if I am right. I discovered this at work because a co-worker of mine found a file saved when he wasn't in office yet (he saved it one hour later than the displayed time).
considered it happens in some rare circumstances and only on some systems, I'm going to call this a wontfix. The time spent trying to workaround it would be better spent elswhere. It's very likely an OS problem.
But thanks for helping in figuring it out.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.