module checksum/version matching for socorro

RESOLVED DUPLICATE of bug 577613

Status

Socorro
General
RESOLVED DUPLICATE of bug 577613
8 years ago
6 years ago

People

(Reporter: Josh Aas, Unassigned)

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
I'd like to propose a pretty simple server-side solution for adding version data to modules that don't have versions in the crash report.

Right now we maintain a list of checksums for Flash binaries on Mac OS X and their corresponding version numbers.

https://wiki.mozilla.org/CrashKill/Mac_Flash_Identifiers

When we need to know the version of Flash for a particular report, we just manually look for the match. This works but it isn't ideal. I think there is a pretty elegant and general solution for this problem that we can implement server-side. It doesn't need to be specific to Flash on Mac OS X.

Would it be possible to keep a database of module checksums and corresponding version strings? This could be updated by QA or anyone else internally, hopefully through a web interface. Then when we attempt to display a module with no version string we can attempt to resolve a version string against the database by looking for a checksum match. This would work on Linux and Mac OS X where modules never have version data.

This idea came out of bug 503181.
This depends on us having an admin panel, which is coming soon. I definitely think we should do this when we don't have the version information. But I also think we should do a better job of getting that data from the user's system before submission and only fallback when that fails.

(In the case of specific Flash, we really just need to get version info. For the more general case, this bug is good.)

Note also that right now module information isn't stored in the db but is stored in the json file, so this might also depend on the new system the metrics team is working on.
(Reporter)

Updated

8 years ago
Blocks: 503181
We have an admin panel, but nobody is driving this feature.  Is this still needed, and if so are you the point for it if we have questions, Josh?
Target Milestone: --- → 1.9
For Flash in particular, you could also use the data from macdebugids.json in dbaron's http://hg.mozilla.org/users/dbaron_mozilla.com/crash-data-tools/ scripts, which should be easier to parse than the wiki.

Updated

7 years ago
Depends on: 577613
Target Milestone: 1.9 → ---
(Assignee)

Updated

6 years ago
Component: Socorro → General
Product: Webtools → Socorro

Comment 4

6 years ago
This is going to be solved by Dragnet.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 577613
You need to log in before you can comment on or make changes to this bug.