Thunderbird windows cycle rapidly when many windows are open, due to bad interaction with Vista's desktop window manager dwm.exe

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: daira, Unassigned)

Tracking

({perf})

x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird version 2.0.0.23 (20090812)

Each Thunderbird window is brought to the front of the Z-order in quick succession, with the cycle of windows repeating many times. After some time (typically a minute or so), the cycling stops. This repeats every so often, say every half an hour.


Reproducible: Sometimes

Steps to Reproduce:
1. Open many Thunderbird windows, say 100.
2. Wait.

The problem only happens when dwm.exe (the Desktop Window Manager process) is running with increased CPU usage. I'm not sure what exactly triggers that.

This problem has been present since before Thunderbird 2.0.

Actual Results:  
The Thunderbird windows cycle to the front as described above, and the application is unusable while this is happening. Other applications are not affected. The cycling eventually stops, but that may take minutes in some cases. The cycling time seems to increase the longer Thunderbird has been open. (I often have it open for several days.)

Expected Results:  
Nothing special.

Killing dwm.exe stops the cycling. Disabling the Desktop Window Manager service appears to fix the problem permanently. (To do that, run compmgmt.msc; accept the elevation prompt; click 'Services' under 'Services and Applications'; double-click 'Desktop Window Manager Session Manager'; set Startup type to Disabled. It's harmless, although of course you lose the Aero effects.)

It is entirely possible that the responsibility for this problem lies mainly with DWM (which is useless bloatware that demonstrates a profound lack of understanding of GUI implementation on Microsoft's part). On the other hand, no other application that I'm aware of has this bad interaction with DWM, which makes Thunderbird almost unusable on Vista when a large number of windows are open. It is not due to a virus pretending to be dwm.exe.
(Reporter)

Updated

9 years ago
Version: unspecified → 2.0

Comment 1

9 years ago
I doubt version 3 behaves better. but if you try it ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-1.9.1/  backup your profile before using. The fundamental issue is probably, as you say, vista
 http://social.technet.microsoft.com/Forums/en-US/itprovistadesktopui/thread/cc697613-ee43-4297-85b6-ab5634b4f0ef 
 http://answers.yahoo.com/question/index?qid=20070414073413AAEcmYU
 http://www.tomshardware.com/forum/234754-44-permanently-disable
 
curious - under what circumstances does one get 100 windows, or even, say 30?
Severity: critical → major
Keywords: perf
Summary: Thunderbird windows cycle rapidly when many windows are open, due to bad interaction with Vista's desktop window manager → Thunderbird windows cycle rapidly when many windows are open, due to bad interaction with Vista's desktop window manager dwm.exe

Comment 2

9 years ago
on further reflection, i seem to recall a similar bug being closed invalid but I can't find it. In any event, please reopen if you see problems with version 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.