Closed Bug 525206 Opened 10 years ago Closed 9 years ago

Quicksearch "Search all messages" (and quick filters) don't work from Account Central

Categories

(Thunderbird :: Search, defect)

defect
Not set

Tracking

(blocking-thunderbird3.1 -)

RESOLVED WORKSFORME
Tracking Status
blocking-thunderbird3.1 --- -

People

(Reporter: bugzilla2007, Unassigned)

References

Details

STR

1 in folder pane, set focus on account -> see Account Central on the right (read messages, write a new message etc.)
2 type searchword in quicksearch bar

Actual
a) "Search all messages" doesn't do anything
b) quick filters don't do anything

Expected
a) "Search all messages" should do just that (it really shouldn't matter where you start from), we should just open a new tab and do the search
b) separate bug needed and ui-wanted for quick filtering from account central:
- maybe we could open a new tab with thread pane on top and preview on bottom, containing all matches for just this account.
for search all messages error console >
 Warning: function onxblkeypress does not always return a value
Source File: chrome://messenger/content/search.xml
Line: 143, Column: 37
Source Code:

nothing in error console for quick search 

is it known whether this ever worked, i.e. is it a regression?
Whiteboard: [regression?]
(In reply to comment #1)
> for search all messages error console >
>  Warning: function onxblkeypress does not always return a value
> Source File: chrome://messenger/content/search.xml
> Line: 143, Column: 37
> Source Code:

Wayne, is that gloda's "Search all messages" from quicksearch box of account central? If yes, please post exact version of TB and OS.

I don't see that error on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091121 Thunderbird/3.0
(rc1 build3)

> nothing in error console for quick search
is that "traditional quick search filters" or "Search all messages" from the quicksearch box? (no errors here on either)

> is it known whether this ever worked, i.e. is it a regression?
well, no. gloda wasn't there in tb2, and quick filters didn't work either (just checked). in tb3, my feeling tells me they both never worked. Actually, we'd need UIwanted for the quickfilter part. An easy workaround solution would be to hide the quickfilter options from the dropdown when we're on account central and always show "Search all messages" only.

That's why this is mainly about "Search all messages" which could easily and therefore should work.
Summary: "Search all messages" (and quick filters) don't work from Account Central → Quicksearch "Search all messages" (and quick filters) don't work from Account Central
search all
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.5) Gecko/20091117 Thunderbird/3.0
Duplicate of this bug: 531412
Would be nice for 3.1 ...
Flags: blocking-thunderbird3?
Flags: blocking-thunderbird3? → blocking-thunderbird3.1?
Duplicate of this bug: 532835
I don't think this is a blocker, but it should be easy enough to fix, and we should. Or, we should hide the search box when displaying account central, if that's way easier. Bryan, let me know if you disagree.
blocking-thunderbird3.1: --- → -
Flags: blocking-thunderbird3.1?
Flags: wanted-thunderbird+
No need to hide the search box altogether (please don't), as mentioned in comment 2:

> An easy workaround solution would be to hide the quickfilter options from the
> dropdown when we're on account central and just show "Search all messages"
> only.

We do the same for gloda search results (where the dropdown has only "Search all messages"), so looking at the code there should make this pretty easy.
(In reply to comment #2)
> An easy workaround solution would be to
> hide the quickfilter options from the dropdown when we're on account central
> and always show "Search all messages" only.

Thomas D.(bug opener), several questions about "Search all messages". 
(Q1) In drop down menu, what is pre-selected when "Search all messages" is displayed in quick search box?
(Q2) After explicit selection(click) of one of filters in drop down menu, can you see "Search all messages" in quick search box again?

I saw next phenomena.
  - "Subject or From filter" is checked with Tb3.0.3.
  - No item corresponds to "Search all messages" is seen in drop down menu.
  - If drop down menu is closed without any click at drop down menu,
    "Search all messages" is still displayed.
  - Once one of filters in drop down menue is selected, unable to see
    "Search all messages", execpt next.
    - Restart Tb3.0.3. Before dialog for default mailer, "Search all messages"
      is displayed in quick search box.
      After close of the dialog, selected filter is displayed in the box.
    - Start Tb 3.2a1pre(trunk nightly) using same profile for Tb 3.0.3,
      select "Entire message filter", terminate Tb 3.2a1pre, restart Tb 3.0.3
      using same profile
      => "Search all messages" is displayed in quick search box
It looks next;             
  Tb 3.0.3
  - selected attribute is set for "Subject or From filter" option,
    but it's not used for currently selected option by user.
  - User selection of filter is not initialized(none is selected).
  - If none is selected, or "Entire message filter" is selected internally,
    "Search all messages" is displayed.
  - There is no UI to select "Search all messages".

Tb 3.2a1pre already has option of "Entire message filter" in drop down menu.
Thomas D.(bug opener), can you reproduce your problem with Tb 3.2a1pre?

By the way, tool bar customization of Tb3 used label of "Global Search" for "quick search box".
(In reply to comment #9)
> Thomas D.(bug opener), several questions about "Search all messages". 
> (Q1) In drop down menu, what is pre-selected when "Search all messages" is
> displayed in quick search box?
Search all messages is ticked with a dot, as it should.
> (Q2) After explicit selection(click) of one of filters in drop down menu, can
> you see "Search all messages" in quick search box again?
It correctly selects (ticks) the filter, and grey filter text is correctly shown in the box. Search all messages is still on the dropdown, and I can correctly select it. Only they all don't work (this bug).

> I saw next phenomena.
>   - "Subject or From filter" is checked with Tb3.0.3.
>   - No item corresponds to "Search all messages" is seen in drop down menu.
I don't understand, "Search all messages" is missing on the dropdown?

> Tb 3.2a1pre already has option of "Entire message filter" in drop down menu.
> Thomas D.(bug opener), can you reproduce your problem with Tb 3.2a1pre?

My Tb 3.2 installation is currently broken, sorry.

> By the way, tool bar customization of Tb3 used label of "Global Search" for
> "quick search box".

Bug 545955 wants to move quick filters into a separate filter bar, which will change the scenario for this bug, and the workaround proposed in comment 2 (only show "search all messages" on account central) will actually be the default anyway. But it still needs to work (this bug).
(In reply to comment #7)
> I don't think this is a blocker, but it should be easy enough to fix, and we
> should. Or, we should hide the search box when displaying account central, if
> that's way easier. Bryan, let me know if you disagree.

That make sense, though this behavior is already a part of the new quick search in bug 545955 so I feel like we'll be closing this bug without making the change.
WFM Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b3pre) Gecko/20100729 Shredder/3.2a1pre
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Ludo, I see this now works, but would you know which bug/changeset fixed this?
It would be better to mark it fixed, if we can (to acknowledge there was a bug in the first place, and to add to our statistics of fixed bugs). Reading comment 11, I think we can safely assume this was fixed by bug 545955?
Whiteboard: [regression?]
I don't. If I'd knew I would have resolved fixed :-)
You need to log in before you can comment on or make changes to this bug.