bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

When editing a pre-existing google calendar event's "reminders", it is thereafter set to "no reminder."

RESOLVED WORKSFORME

Status

Calendar
Provider: GData
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: swordphsh, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.14) Gecko/2009090217 Ubuntu/9.04 (jaunty) Firefox/3.0.14
Build Identifier: Lightning version 1.0pre Build ID: 20091029040828, GData v0.6pre (latest nightly build)

After creating an event in the google calendar using lightning, if I go back to edit the event's reminders, they are all cleared and set to "no reminder," and cannot be saved to anything else without deleting and recreating the event.

Reproducible: Always

Steps to Reproduce:
1. Create new event in a google calendar
2. Save
3. Edit event and make a change to reminder
4. Save and close, event reminders disappear
5. Re-edit event, reminders = "no reminders"
6. Set a reminder, save and close.
7. Reminders are still set to "no reminders"
Actual Results:  
Reminders are permanently set to "no reminders" on event, unless it is deleted and recreated.

Expected Results:  
It should have set the specified reminders.

This is only a problem with the google calendar. It is not present while using a local calendar. I update thunderbird, lightning, GData to nightly builds daily.
(Reporter)

Comment 1

9 years ago
Here are the debug messages which appears upon editing the event and changing the alert type (in "First > Last Sort Order):

Modifying item New Event

Logging object...
action: Setting Upload Data:
content: application/atom+xml; charset=UTF-8
data: <entry xmlns:gd="http://schemas.google.com/g/2005" xmlns:gCal="http://schemas.google.com/gCal/2005" xmlns="http://www.w3.org/2005/Atom">
  <category scheme="http://schemas.google.com/g/2005#kind" term="http://schemas.google.com/g/2005#event"/>
  <title type="text">New Event</title>
  <content type="text"/>
  <author>
    <name>name</name>
    <email>swordphsh@gmail.com</email>
  </author>
  <gd:transparency value="http://schemas.google.com/g/2005#event.opaque"/>
  <gd:eventStatus value="http://schemas.google.com/g/2005#event.confirmed"/>
  <gd:where valueString=""/>
  <gd:who email="swordphsh@gmail.com" rel="http://schemas.google.com/g/2005#event.organizer" valueString="name"/>
  <gCal:sendEventNotifications value="true"/>
  <gd:when startTime="2009-11-03T17:00:00-05:00" endTime="2009-11-03T18:00:00-05:00"/>
  <gd:visibility value="http://schemas.google.com/g/2005#event.default"/>
  <gCal:sequence value="0"/>
  <gCal:uid value="2r7k09238tek11focmn3m3mkc0"/>
</entry>
End object

calGoogleRequest: Requesting PUT http://www.google.com/calendar/feeds/swordphsh%40gmail.com/private/full/2r7k09238tek11focmn3m3mkc0/63392793833?ctz=America%2FNew_York

Logging calIEvent:
	id:2r7k09238tek11focmn3m3mkc0
	editurl:http://www.google.com/calendar/feeds/swordphsh%40gmail.com/private/full/2r7k09238tek11focmn3m3mkc0/63392793833
	created:2009/11/01 16:23:53 America/New_York isDate=0
	updated:2009/11/01 16:23:53 America/New_York isDate=0
	title:New Event
	content:null
	transparency:OPAQUE
	status:CONFIRMED
	startTime:2009/11/03 17:00:00 America/New_York isDate=0
	endTime:2009/11/03 18:00:00 America/New_York isDate=0
	location:null
	privacy:DEFAULT
	alarmLastAck:null
	snoozeTime:null
	isOccurrence: false
	Organizer: 
		ID: mailto:swordphsh@gmail.com
			Name: name
			Rsvp: FALSE
			Is Organizer: yes
			Role: null
			Status: null
	Attendees: 
	recurrence: no
	alarms: no
(Reporter)

Comment 2

9 years ago
I have noticed that the bug is prevalent with any editing of a calendar event, not just alert editing.

Comment 3

9 years ago
I think this is the same as 474983
bug 474983 is rather related to CalDAV. Are you using the experimental cache, if so see bug 477287.

I should definitely look into Google Calendar and alarms, seems like there are a lot of issues.
I've tested this issue with the latest versions and it now works for me. Please reopen if you still experience the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

9 years ago
The issue appears to have resolved itself after I disabled the experiemental cache. I had enabled the cache to work around the issue of alarms recurring at reload.
You need to log in before you can comment on or make changes to this bug.