Unable to specify search terms to be *excluded*

RESOLVED DUPLICATE of bug 559216

Status

P4
enhancement
RESOLVED DUPLICATE of bug 559216
9 years ago
3 years ago

People

(Reporter: rogat.info.rogatandreas, Unassigned)

Tracking

unspecified
Future

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729)

searching details: row bar multi -mls
When i search at Google i can specify my search with "+" and "-", and there are "boolean operators" too!
At Mozilla Addons Website i cannot filter esp. "MLS" from results.

Reproducible: Always

Steps to Reproduce:
1. search for "row bar multi"
2. search for "row bar multi -mls"
3. you get that (like at Google search): row bar multi mls
Actual Results:  
3. you get that (like at Google search): row bar multi mls

Expected Results:  
like at Google search: row bar multi -mls
without "mls" search results

Why not "Google Search" engine at mozilla.org?!
I was also unable to find a syntax for excluding specific terms, such as "adblock -plus" or "adblock !plus".

Dave, is that intended behavior? Is it easy to add? I think it'd be helpful to have any kind of negation operator.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Summary: https://addons.mozilla.org/de/firefox/search?q=row+bar+multi+-mls&cat=all&as=1&appid=1&lver=3.5&atype=1&pp=100&pid=5&sort=newest&lup=3+months+ago → Unable to specify search terms to be *excluded*
use - plz
Priority: -- → P4
Target Milestone: --- → Future
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 559216
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.