Account Wizard dialogs are blank with Classic skin

VERIFIED FIXED

Status

SeaMonkey
MailNews: Account Configuration
P3
critical
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: Alec Flett)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][dogfood-])

(Reporter)

Description

17 years ago
I thought there was a bug already reported on this but I can't find it.

Build 2000-09-13-06M18: NT4, Linux 6.0, Mac 9.04

Overview: Using the Classic skin results in various problems with the Account 
Wizard dialogs.

Steps to reproduce:
1. Change to the Classic skin
2. Select Edit|Mail/News Account Settings to open the Account Settings dialog
3. Select the "New Account" button to open the Account Wizard

Actual Results:
- Linux: The dialog is completely blank but the buttons on the bottom are 
present (Cancel, Back, Next, Finish). Select the Cancel button and the Linux 
console states "Javascript Error: line 0: wizardManager is not defined". 
Selecting the Cancel button does nothing. Selecting the "x" box closes the 
Account Wizard. 

- Mac: Again the dialog is blank and the Cancel button does nothing. I can't 
close the dialog because no close box/control exists.

- NT4: Better than Linux or Mac. I see text in the dialog but the dialog titles 
are gone. The titles should state the name of the panel for instance "Identity" 
instead there is a large white rectangular space.

Expected Results: The Account Wizard dialogs should not be blank in the Title 
area or main body of each dialog.

Additional Information:
- Using the Modern skin is OK on all platforms.
(Reporter)

Updated

17 years ago
Keywords: dogfood, nsbeta3
QA Contact: esther → nbaca
(Assignee)

Comment 1

17 years ago
I already have a fix ready for when the tree opens!
Status: NEW → ASSIGNED
Whiteboard: fix in hand

Comment 2

17 years ago
marking nsbeta3+.
Whiteboard: fix in hand → [nsbeta3+] fix in hand
(Reporter)

Updated

17 years ago
Blocks: 48438
(Assignee)

Updated

17 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

17 years ago
fix is in
(Reporter)

Comment 4

17 years ago
Reopening

Classic:
- Mac 9.04, Build 2000-09-21-04M18: Not Fixed, Title of dialog not displaying:
It's better because most of the elements of the dialog are present except the 
Title of the dialog is blank.

- NT4, Build 2000-09-21-12M18: Fixed, all dialog elements are present including 
the Title.
- Linux 6.0, Build 9/21, Build ID 2000091312: Fixed.  all dialog elements are 
present including the Title.

Modern: Dialog Titles are not appearing on all platforms.
Should I log a seperate bug for this problem?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 5

17 years ago
It sounds like the only missing element is the title... and that leaves this
(now) as dogfood-minus
Removing "fix-in-hand"note, as that related to original fix.

I'd suggest logging a separate bug for this... thu dialogs are certainly not
blank anymore.
Whiteboard: [nsbeta3+] fix in hand → [nsbeta3+][dogfood-]
(Reporter)

Comment 6

17 years ago
Verified Fixed since the body of the Account Wizard dialogs are no longer blank. 

Logged another bug regarding Account Wizard's title area being blank in certain 
situations (bug# 54028)
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

17 years ago
Really marking Verified this time.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.