If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

###!!! ASSERTION: bad width: 'Not Reached', layout/generic/nsLineLayout.cpp

RESOLVED DUPLICATE of bug 531361

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 531361
8 years ago
8 years ago

People

(Reporter: Natch, Unassigned)

Tracking

({assertion, testcase})

Trunk
x86
Windows Vista
assertion, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
###!!! ASSERTION: bad width: 'Not Reached', /mozilla-central/layout/generic/nsLineLayout.cpp, line 180
Block(li)(1)@063AD088: Init: bad caller: width WAS 6000000(0x5b8d80)
Block(li)(1)@063AD088: UpdateBand: bad caller: width WAS 5994032(0x5b7630)
Block(li)(1)@063AD088: UpdateBand: bad caller: width WAS 5988064(0x5b5ee0)
Block(li)(1)@063AD088: UpdateBand: bad caller: width WAS 5982096(0x5b4790)
Block(li)(1)@063AD088: UpdateBand: bad caller: width WAS 5976128(0x5b3040)
nsBlockReflowContext: Block(li)(1)@063AD088 metrics=6000000,0!
nsBlockReflowContext: Block(ol)(1)@063ACDF8 metrics=6000000,0!

I get this spew on m.www.yahoo.com.
The code that outputs this NOTREACHED is:

167 void
168 nsLineLayout::BeginLineReflow(nscoord aX, nscoord aY,
169                               nscoord aWidth, nscoord aHeight,
170                               PRBool aImpactedByFloats,
171                               PRBool aIsTopOfPage)
172 {
[SNIP]
179   if ((aWidth != NS_UNCONSTRAINEDSIZE) && CRAZY_WIDTH(aWidth)) {
180     NS_NOTREACHED("bad width");

So it looks like the page has some line with a gigantic (one might even say "crazy") width.

Note that CRAZY_WIDTH() just checks if aWidth is outside the range [-500000, 500000]
It's defined here:
http://mxr.mozilla.org/mozilla-central/source/layout/generic/nsHTMLContainerFrame.h#57
Keywords: testcase-wanted
(Reporter)

Comment 2

8 years ago
Created attachment 409251 [details]
testcase

Yeah, they set the width to 100,000px. They do this in combo_002.css, but I've combined the files for easy test-casing.
(Reporter)

Updated

8 years ago
Keywords: testcase-wanted → testcase

Comment 3

8 years ago
I can confirm the bug on Windows 7 x86 with XULRunner compiled from mozilla-1.9.1 sources for firefox, on various links on www.youtube.com browsed with embedded Gecko (with nsIWebBrowser).
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 531361
You need to log in before you can comment on or make changes to this bug.