Add a Keyword for this Search causes "node must have _DOMElement set" assertions

RESOLVED DUPLICATE of bug 528006

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 528006
10 years ago
10 years ago

People

(Reporter: theodorejb, Unassigned)

Tracking

({qawanted, regression})

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b1) Gecko/20091029 Firefox/3.6b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b1) Gecko/20091029 Firefox/3.6b1

On many sites, if I try to add a keyword for a search box, I get error messages.

Reproducible: Always

Steps to Reproduce:
1. Did a clean install of Firefox 3.6 beta (build 3)
2. On the default home page (google.com/firefox), adding a keyword worked fine.
3. Went to bing.com and tried to add a keyword
4. Got error messages.
5. Went to news.google.com and tried to add a keyword for the search.
6. Got similar error messages (see Actual Results)
7. Every site I try gives me error messages if I try to add a keyword for search (even google.com)
Actual Results:  
ASSERT: parent node must have _DOMElement set
Stack Trace: 
0:PMV_nodeInserted([object ResultNodeClassInfo],[object ResultNodeClassInfo],8)
1:insertBookmark(2,[xpconnect wrapped nsIURI],-1,Search Google News)
2:PCIT_doTransaction()
3:doTransaction()
4:PAT_commit(false)
5:PAT_doTransaction()
6:doTransaction([xpconnect wrapped nsITransaction])
7:placesTxn_doTransaction([xpconnect wrapped nsITransaction])
8:doTransaction([xpconnect wrapped nsITransaction])
9:BPP__getCreateItemTransaction()
10:BPP__fillAddProperties()
11:BPP_onDialogLoad()
12:onload([object Event])

If I click "OK", it brings up the add keyword dialogue box, when I try to change the folder, I get another error:

ASSERT: node must have _DOMElement set
Stack Trace: 
0:PMV__nodeTitleChanged([object ResultNodeClassInfo],Google News)
1:setItemTitle(66,Google News)
2:PEITT_doTransaction()
3:doTransaction()
4:PAT_commit(false)
5:PAT_doTransaction()
6:doTransaction([xpconnect wrapped nsITransaction])
7:placesTxn_doTransaction([xpconnect wrapped nsITransaction])
8:doTransaction([xpconnect wrapped nsITransaction])
9:EIO_onNamePickerChange()
10:onblur([object Event])

If I click "cancel", I get another error:

ASSERT: parent node must have _DOMElement set
Stack Trace: 
0:PMV_nodeRemoved([object ResultNodeClassInfo],[object ResultNodeClassInfo],8)
1:removeItem(67)
2:PCIT_undoTransaction()
3:undoTransaction()
4:PAT_commit(true)
5:PAT_undoTransaction()
6:undoTransaction()
7:placesTxn_undoTransaction()
8:undoTransaction()
9:BPP_onDialogCancel()
10:anonymous([object Event])
11:_fireButtonEvent(cancel)
12:_doButtonCommand(cancel)
13:_handleButtonCommand([object XULCommandEvent])


Expected Results:  
Should allow adding keywords without errors, like it did for the first keyword I tried (Firefox home page).

After clicking through all the error messages, the keyword is finally added and works.

Not using any themes, all settings default (except smooth scrolling is enabled, update settings set to "ask", and download directory set to "ask".
Also I moved the "home" button to the bookmark bar and took the Most Visited and getting started buttons into the bookmarks menu.
Mano, this looks similar to that crash with assertion.

Theodore: apart the clean install, is this also a clean new profile?
Summary: Add a Keyword for this Search causes error messages → Add a Keyword for this Search causes "node must have _DOMElement set" assertions
Theodore, please open the Error Console, in the Eval field paste this text and click Eval. Paste here the output you will get in the console.

Components.utils.import("resource://gre/modules/PlacesDBUtils.jsm");
PlacesDBUtils.checkAndFixDatabase();
Blocks: 498130
Keywords: regression
Keywords: qawanted
Reporter

Comment 3

10 years ago
Yes, this is also a clean profile.

Results from Error Console:

INTEGRITY
ok
- - -
CLEANUP
- - -
VACUUM
places.sqlite: 167936 byte
- - -
STATS
places.sqlite: 167936 byte
moz_bookmarks: 66
moz_bookmarks_roots: 5
moz_keywords: 3
sqlite_sequence: 1
moz_favicons: 12
moz_annos: 3
moz_anno_attributes: 11
moz_items_annos: 26
moz_places: 77
moz_historyvisits: 22
moz_inputhistory: 1
- - -
Reporter

Comment 4

10 years ago
After seemingly hundreds of clean installs (with clean profiles), I'm still trying to figure this out. I've learned a couple things, at least. 
1: If I don't change ANY settings or modify ANY defaults, the errors don't occur.
2: When I do get the errors, it's only on the browser's first run. Restarting the browser makes the errors go away.
I haven't figured out yet which settings changes are causing the problem.
note: in Bug 525604 the problem was caused by an extension.

Please keep going testing, if you could find some common point to reproduce this would greatly help us.
While running Litmus tests Tobias has also seen this bug. Sadly it has been solved on its own (probably after a restart) which makes it hard to reproduce. Tobias, would you be so kind to check if you can reproduce it by running the tests again? That would be fantastic. Thanks.

Confirming based on multiple reportings.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 528006
Bug 528006 has better steps to reproduce. Lets move over any work there.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 528006
You need to log in before you can comment on or make changes to this bug.