Last Comment Bug 525539 - (SQLite3.6.16.1) Upgrade to SQLite 3.6.16.1
(SQLite3.6.16.1)
: Upgrade to SQLite 3.6.16.1
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: Storage (show other bugs)
: Trunk
: All All
P2 normal (vote)
: mozilla1.9.3a1
Assigned To: Shawn Wilsher :sdwilsh
:
: Marco Bonardo [::mak]
Mentors:
Depends on:
Blocks: SQLite-OP_If 538747
  Show dependency treegraph
 
Reported: 2009-10-30 13:13 PDT by Shawn Wilsher :sdwilsh
Modified: 2010-01-10 05:05 PST (History)
9 users (show)
mbeltzner: blocking1.9.2+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
beta2-fixed
.6-fixed


Attachments
v1.0 (3.52 KB, patch)
2009-10-30 13:18 PDT, Shawn Wilsher :sdwilsh
no flags Details | Diff | Splinter Review
1.9.1 v1.0 (3.65 KB, patch)
2009-10-30 13:40 PDT, Shawn Wilsher :sdwilsh
dveditz: approval1.9.1.6+
Details | Diff | Splinter Review

Description User image Shawn Wilsher :sdwilsh 2009-10-30 13:13:25 PDT
We want to take this upgrade to fix crash bug 523405.  This is a common crash that occurs when people try to delete more than 32k history entries (which is apparently common).
Comment 1 User image Shawn Wilsher :sdwilsh 2009-10-30 13:18:17 PDT
Created attachment 409401 [details] [diff] [review]
v1.0

We don't do review for upgrades since it's just a code drop.  Here it is (Mozilla and SQLite changes all in one patch).
Comment 2 User image Shawn Wilsher :sdwilsh 2009-10-30 13:31:05 PDT
http://hg.mozilla.org/mozilla-central/rev/b74a57e6d96e
Comment 3 User image Shawn Wilsher :sdwilsh 2009-10-30 13:36:05 PDT
Comment on attachment 409401 [details] [diff] [review]
v1.0

This applies (with fuzz 1) on 1.9.2.
Comment 4 User image Shawn Wilsher :sdwilsh 2009-10-30 13:40:04 PDT
Created attachment 409403 [details] [diff] [review]
1.9.1 v1.0

Did not apply cleanly to 1.9.1 though, but this one will.
Comment 5 User image Shawn Wilsher :sdwilsh 2009-10-30 14:19:59 PDT
This also impacts 1.9.0, but we have SQLite version 3.6.10 there (not 3.6.16).  Are we interested in taking this there?  It'd be a much bigger patch there.
Comment 6 User image Shawn Wilsher :sdwilsh 2009-11-02 11:50:29 PST
Comment on attachment 409401 [details] [diff] [review]
v1.0

Blocking, so I no longer need approval.
Comment 7 User image Shawn Wilsher :sdwilsh 2009-11-02 11:54:31 PST
Landed on 1.9.2:
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/b443a49e0185
Comment 8 User image Daniel Veditz [:dveditz] 2009-11-02 14:28:57 PST
Comment on attachment 409403 [details] [diff] [review]
1.9.1 v1.0

Approved for 1.9.1.6, a=dveditz for release-drivers
Comment 9 User image Shawn Wilsher :sdwilsh 2009-11-02 15:48:48 PST
Landed on 1.9.1:
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/c4c7d2498e2e
Comment 10 User image chris hofmann 2009-11-17 21:57:01 PST
I'm seeing a possible new signature sqlite3VdbeDelete show up in early 3.6beta3 that we didn't see in b1 or b2.

could that be a possible regression from this landing?  the dates don't seem to line up. 

see bug 529478 for the b3 bug.
Comment 11 User image Samuel Sidler (old account; do not CC) 2009-11-17 22:18:49 PST
(In reply to comment #10)
> I'm seeing a possible new signature sqlite3VdbeDelete show up in early 3.6beta3
> that we didn't see in b1 or b2.

Take a look at the patch... I really, really doubt it.

Note that we saw that crash on 1.9.1 in the last week as well...
Comment 12 User image Reed Loden [:reed] (use needinfo?) 2009-11-17 22:31:26 PST
I would mention bug 524144, but it's only landed on trunk and not 1.9.2 or 1.9.1...

Note You need to log in before you can comment on or make changes to this bug.