Add DreamFactory plugin to the Plugin Finder Service

RESOLVED DUPLICATE of bug 550540

Status

P5
enhancement
RESOLVED DUPLICATE of bug 550540
9 years ago
3 years ago

People

(Reporter: lee.hicksjr, Unassigned)

Tracking

unspecified
Future
x86
All

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4

DreamFactory has over 4000 companies who use our products on various platforms, many using FireFox on Windows or Mac. We need an easier, more streamlined way for the customers to get the plugin installed. This process is seamless on Internet Explorer, but manual install is still required for FireFox. Packaging the plugin as an extension was attempted but denied public listing due to the binary nature of the plugin.

Our mime-type is application/dreamfactory.
Filing this as a bug was requested by Add-On reviewers.
DreamFactory plugin is currently supported on MS Windows and Mac OS, but not Linux.

Reproducible: Always

Steps to Reproduce:
1. Without having manually installed the dreamfactory plugin. Go to http://www.dreamfactory.net/desktop/enterprise_entrance.html
2. You get the prompt to "Install missing plugins", click the button or the page.
3. Dialog prompts for manual install due to "No suitable plugins were found."
Actual Results:  
Plugin must be manually installed from our website either from the "Manual Install" button, or by contacting our customer support.

Expected Results:  
We would like to have the plugin automatically found, verified and installed like Flash, Quicktime, etc.

Filing this request as a bug was requested by Jorge Villalobos, cc'd by Nick Nguyen, and Justin Scott.
Severity: normal → enhancement
Priority: -- → P5
Target Milestone: --- → Future

Comment 1

8 years ago
Verified with MACOS - FF3.6.9

Noticed the same message as given in the actual result: "No suitable plugins were found"

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 550540
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.