Clicking on image with anchor draws hspace and vspace rects

VERIFIED FIXED in Future

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Chris Petersen, Assigned: Kevin McCluskey (gone))

Tracking

({css2})

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Build: 2000091220
Platforms: All
Expected results: Vspace or hspace rectangle shouldn't appear when clicking 
image.
What I get: A rectangle is drawn below image when mousing down on image.

Steps to reproduce:

1) Open http://slip/projects/marvin/simple/img_vspace_hspace.html

2) Mouse down on either vspace or hspace image. Notice a rectangle is displayed 
below the image.
(Reporter)

Updated

18 years ago
Component: HTML Element → ImageLib
(Reporter)

Comment 1

18 years ago
Changing QA assigned.
QA Contact: lorca → petersen
(Reporter)

Comment 2

18 years ago
This problem is occuring at kodak's page.

http://kodak.com/US/en/corp/pps/prizes.shtml

Click on any of the photo thumbnails and you will see a rectangle appear below 
the image. The HSPACE attribute is used in the img element.
HSPACE is actually not the cause, the cause is that the dotted outline is
going around the <A> element's font-size (which is what we intended).

This is probably a duplicate of a bug to do with drawing outlines around all
the contents of inline elements.

It looks even worse if you use a transparent image without margins or vspace --
then you get a dotted outline _behind_ the image...
Component: ImageLib → Layout
Keywords: css2
Target Milestone: --- → Future
(Assignee)

Comment 4

18 years ago
Dividing up Claytons bugs to triage
Assignee: clayton → kmcclusk
(Assignee)

Comment 5

18 years ago
Not seeing rectangle when clicking on images on the kodak site using 12/13/2000
build on WINNT.
Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

18 years ago
Verified fixed in the 2001010209 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.