Favicon cache cannot be manually cleared

RESOLVED DUPLICATE of bug 229985

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 229985
8 years ago
5 years ago

People

(Reporter: P.J., Unassigned)

Tracking

3.5 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4

I cannot see updates to my favicon because Firefox caches it once and never (or rarely) clears that cache. Even manually clearing the cache from the Tools -> Clear Recent History does nothing.

Reproducible: Always

Steps to Reproduce:
1. View a site with a Favicon
2. Upload a new Favicon
3. Clear cache
4. View site again. Same old cached Favicon
Actual Results:  
Still see the same old cached Favicon

Expected Results:  
Display the new Favicon, clear Favicon cache when clearing cache.

Comment 1

8 years ago
I agree. In fact I was going to file this as a bug when I came across this already-filed report. Would like FF to clear all favicons when I use the "Clear Recent History" feature with "Everything" chosen (Firefox 3.6.3).

Additionally, this is a privacy bug as the persistence of favicons indicates that the user visited a particular website/webpage.

Comment 2

7 years ago
Not only on MacOS, the same bug is on Windows & Linux. Firefox should find out that the favicon has changed, or at least allow users to clear the cache manually bud it doesn't. Users are stuck with original favicon forever, no way to update it.

Updated

7 years ago
Version: unspecified → 3.5 Branch

Comment 3

7 years ago
Once a Favicon has been cached it seems unwilling to be amended, updated or removed. In the case of bookmarks with incorrect favicons it is apparently impossible to dislodge an incorrect association.
There's been dozens of bugs surrounding favicons created and marked "fixed" on multiple versions of FF since around 2.0 - BUT >>>it's still showing dodgy behaviour in 5.0<<<

I've spent considerable time fiddling with favicons for a couple of my sites, the only way I can reliably display them is in MSIE.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 229985
You need to log in before you can comment on or make changes to this bug.