Ctrl+K doesn't select existing search terms in quicksearch box

RESOLVED FIXED

Status

--
minor
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: bugzilla2007, Assigned: janmoesen_=-bugzilla-=+spamtrap)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

STR

1 e.g. in main window, write some search words into quicksearch box (do not press enter)
2 press ctrl+k

actual
- focus is set to search box, but search words aren't selected

expected
- focus is set to search box, and search words are selected
(this is the current behaviour in TB2, and in FF, too)

This will make it easier to do a new search/filter for something else.
(Reporter)

Updated

9 years ago
Severity: normal → minor
Keywords: regression

Comment 1

9 years ago
and also allow clear of search without mouse or extra keystrokes.
(i rather dislike workflow distruptors like this)
I suspect bug  474711 (so blocking to bug 474701)
Blocks: 474701
Version: 3.0 → Trunk

Updated

9 years ago
Duplicate of this bug: 521971
not sure that this would block the release but it would be good to get fixed and be a bit more consistent in our behaviour.
(Assignee)

Comment 5

9 years ago
Created attachment 428651 [details] [diff] [review]
Replace .focus() by .select()

This fixes the bug/request on my OS X 10.6. The diff is against today's comm-central .dmg; I do not have the whole repository available. Let me know if I need to reformat it.
(In reply to comment #5)
> Created an attachment (id=428651) [details]
> Replace .focus() by .select()
> 
> This fixes the bug/request on my OS X 10.6. The diff is against today's
> comm-central .dmg; I do not have the whole repository available. Let me know if
> I need to reformat it.

Please do  - see https://developer.mozilla.org/en/comm-central#Requirements, You'll need to request a specific reviewer to review you patch.
(Assignee)

Comment 7

9 years ago
I tried #thunderbird and #tb-qa for more info, but there was not much activity there. Did you mean I should reformat the patch? If so, could you expand on that (other diff parameters or a Hg diff against the full checked out source)? Or did you mean should I just ask the correct reviewer?
Ha sorry I should have answered there. hg diff versus a checked out version is what you need. And then when you attach the new patch make sure to set a request review for someone.
(Assignee)

Comment 9

9 years ago
Created attachment 431334 [details] [diff] [review]
hg diff comm-central/mail/base/content/mailWindowOverlay.js
Attachment #428651 - Attachment is obsolete: true
Attachment #431334 - Flags: review?
(Assignee)

Updated

9 years ago
Attachment #431334 - Flags: review? → review?(bugmail)
Comment on attachment 431334 [details] [diff] [review]
hg diff comm-central/mail/base/content/mailWindowOverlay.js

Thank you for the patch!

I have pushed this to the comm-central repo:
http://hg.mozilla.org/comm-central/rev/65ccabf3534a

This should start showing up in 3.1-series nightly builds tomorrow.
Attachment #431334 - Flags: review?(bugmail) → review+
Assignee: nobody → janmoesen_=-bugzilla-=+spamtrap
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 563631
You need to log in before you can comment on or make changes to this bug.