Closed Bug 525598 Opened 11 years ago Closed 10 years ago

Quick Searching (filter) a large smart folder causes CPU to max out and lock up X

Categories

(MailNews Core :: Search, defect, major)

x86_64
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 533865

People

(Reporter: mkanat, Unassigned)

Details

(Keywords: perf)

I was using the "Subject, To, or CC" filter on my "Sent" smart folder (22,000 messages over four accounts), and Thunderbird was doing a "find as you type" on my mail messages, and doing so used up 100% of my CPU and locked up X for about 10 seconds.

This is in 3.0b4.
Oh actually, it lasts about 90 seconds.
Doing it on a single account's Sent folder doesn't cause the problem. Only doing it on the Smart folder causes the problem.
Max are those folders local ? or on an imap account ?
Keywords: perf
They're all in IMAP accounts on a dovecot server that I run.
So you don't download anything localy ?

Could you log the imap protocol with timestamp as described at https://wiki.mozilla.org/MailNews:Logging and attach it here ?
Component: Search → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: search → networking.imap
Version: 3.0 → Trunk
(In reply to comment #5)
> So you don't download anything localy?

  I don't have any POP3 accounts, but all the folders are synchronized locally, as per the TB3 default.

> Could you log the imap protocol with timestamp as described at
> https://wiki.mozilla.org/MailNews:Logging and attach it here ?

  Will do.
Strange--I can't reproduce it today. Perhaps it was dependent upon something else that was happening on my machine the other day, or something else that Thunderbird was doing simultaneously. In any case, it's not currently reproducible, but if it can be reproduced again, I'll open the bug again.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Oh, nevermind. Just reproduced it.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
The log contains personal information regarding my business (folder names that are the names of every client and prospect I've ever had, in addition to the names of other things) so I've encrypted the gzipped log and emailed it to you directly, ludovic, using GPG encryption.
So the log looks ok. 

A few other things you could try :

 Rebuild your sent folder index - and see if that helps .
 What size is your sent folder .msf file ?
quick search isn't done online, so this doesn't have to do with imap networking, and a protocol log shouldn't be interesting.
Component: Networking: IMAP → Search
QA Contact: networking.imap → search
another probable dupe of bug 533865, whose patch is landing soon.
Status: REOPENED → RESOLVED
Closed: 11 years ago10 years ago
Resolution: --- → DUPLICATE
Summary: Searching a large smart folder causes CPU to max out and lock up X → Quick Searching (filter) a large smart folder causes CPU to max out and lock up X
Duplicate of bug: 533865
You need to log in before you can comment on or make changes to this bug.