If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"node must have _DOMElement set" assertion fired using LiveClick Add-on on Firefox 3.6

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: der_tuxman, Unassigned)

Tracking

({assertion})

3.6 Branch
x86
Windows Vista
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.2b1) Gecko/20091029 Firefox/3.6b1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.2b1) Gecko/20091029 Firefox/3.6b1 (.NET CLR 3.5.30729)

With 3.6b1 Firefox only displays half of my bookmarks in its bookmarks bar.

Reproducible: Always

Steps to Reproduce:
If I knew...
Actual Results:  
I just updated my Firefox from 3.5.4 to 3.6b1, and it is the first time that something goes completely wrong. I don't have a clue why but now only half of the bookmarks appear, and they don't have actual icons.

According to the Error Console there's nothing wrong with it.


A screenshot for a better description: http://img689.imageshack.us/img689/2840/mozillafirefox36beta120.png

If I try to move a bookmark in the sidebar an assertion error appears. Maybe this is of any interest? Another screenshot: http://img94.imageshack.us/img94/6338/assertionfailed20091031.png
Mak, does the assertion look familiar?
Keywords: assertion
Version: unspecified → 3.6 Branch
yes, looks similar to bug 525480. has been added along with bug 498130.
Blocks: 498130
We need some good STR to reproduce.
Does this happen in Safe mode? http://support.mozilla.com/kb/Safe+Mode
(Reporter)

Comment 4

8 years ago
In Safe Mode everything works fine (obviously), so there is no actual data loss. The assertion does not appear either.
could you tell me which add-ons you have?
(Reporter)

Comment 6

8 years ago
Quite a bunch of them, cough ... but I really don't know which one should force this behavior.


- Ad Muncher Browser Extensions 2.0
- Add Bookmark Here ┬▓ 3.5.20090920
- Annoyance Remover 2.0b3
- AutoAuth 1.3
- BetterCache 1.24
- BetterPrivacy 1.29
- ColorZilla 2.0.2.1
- CoLT 2.4.5
- Console┬▓ 0.5
- Controle de Scripts 1.0.3
- CookieMan Context 2.1
- Crash Report Helper 1.1
- CSSViewer 1.0.3
- CuteMenus2 3.0
- De-ImageShack 0.6.1
- DOM Inspector 2.0.3
- Download Statusbar 0.9.6.5
- DownloadHelper 4.6.4
- Echofon 1.9.3
- FfvB - vBulletin Management for Firefox 2.2.3
- Find All 2.0
- Firebug 1.4.3b1
- Fission 1.0.9
- FlashGot 1.2.0.7
- FoxyTunes 3.5.9
- FoxyTunes Skin - cleanJR 1.6
- FxIF 0.3.1
- Greasemonkey 0.8.20090920.2
- gui:config 0.4.4
- HashColouredTabs+ 0.4.22
- Hide Find Bar 1.3.1
- Image Zoom 0.3.1
- ImageTweak 0.19
- It's All Text! 1.3.1
- Java Console 6.0.16
- JSView 2.0.5
- keyconfig 20080929
- Linkification 1.3.6
- LiveClick 0.3.4.0
- Locationbar┬▓ 1.0.3
- Microsoft .NET Framework Assistant 0.0.0
- MinimizeToTray revived (MinTrayR) 0.5
- Morning Coffee 1.33
- Mouseless Browsing 0.5.2.1
- MR Tech Toolkit 6.0.3.4
- NoScript 1.9.9.14
- Omnibar 0.6.0.20090913
- OpenDownload 2.1.2
- Organize Status Bar 0.6.3
- PDF Download 3.0.0.1
- Personal Menu 4.2.1
- Perspectives 3.0.3
- PhZilla 3.5.1B
- Pinger 1.0.1
- Power Twitter 1.35
- Read It Later 2.0.0b3
- Redirect Remover 2.5.5
- ReminderFox 1.9.1
- ScribeFire 3.4.5
- Secure Login 0.9.3
- Shorten URL 0.3.0.1
- Silvermel and Charamel XT 1.3.0
- Sitzungs-Manager 0.6.6.2
- SkipScreen 0.1.07282009
- Smart Stop/Reload 1.2
- Smiley Xtra 5.0.2
- SmoothWheel (mozdev.org) 0.44.19.20090811.3
- Stop Autoplay 0.7.6
- Tab Mix Plus 0.3.8.2pre.091012
- Textarea Cache 0.5.5
- Textarea++ 0.1.19
- Toolbar Buttons 0.6.0.8
- Ubiquity 0.5.4
- Update Channel Selector 1.5
- Update Notifier 0.1.5.5
- URL Fixer 1.5
- YouPlayer 0.9.8
- Youtube Tooltip 1.3.2

I tried disabling Xmarks (as you might see), but it didn't help...
omg, this is a long list...

try disabling:
Add Bookmark Here
CuteMenus2
Personal Menu
Toolbar buttons
report if the issue has gone with those disabled

otherwise, you should try to disable them one by one to help us finding what could be related :(
especially Add Bookmark here could interact with our menus...
(Reporter)

Comment 9

8 years ago
(In reply to comment #7)
> omg, this is a long list...

Eheh, yep... I definitely have got too much free time...

Meanwhile I could find out that LiveClick went wrong. ABH works fine. :-)
Having disabled LiveClick removes the assertion problem as well as the "bug" with the missing bookmarks. Thank you very much for your patience, guys!
thanks you for your help, i'll take a look at the code of that extension.

in the meanwhile, please contact the extension author through addons.mozilla.org and make him aware of the problem since it's pretty bad.
Summary: Bookmarks bar only half-populated after update from 3.5.4 → "node must have _DOMElement set" assertion fired using LiveClick Add-on on Firefox 3.6

Updated

8 years ago

Updated

8 years ago
(Reporter)

Comment 11

8 years ago
OK, I'll see. Maybe he's already working on a new version. :-)
invalid since caused by an add-on. this is somehow expected since we changed our code a bit and some add-on did not follow us quickly enough. Probably we should better documenting changes between versions for ext devs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.