Auto Sign in does not work. User ID and password are saved in browser settings

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: provaibhav, Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729)

After installing the new update of firefox 3.5.4, auto sign in has stopped working. Earlier gmail was getting auto logged in just by entering by click on the bookmark link in bookmark toolbar. Its happening with all other websites as well. 

Reproducible: Always

Steps to Reproduce:
1.open www.gmail.com
2.
3.
Actual Results:  
By visiting www.gmail.com, login screen appears with userid and password entered but no auto login event occurs.

Expected Results:  
Auto login should work. It was working in previous version.
Please read http://support.mozilla.com/de/kb/Cannot+log+in+to+websites
Version: unspecified → 3.5 Branch
(Reporter)

Comment 2

9 years ago
I already have this setting as default. Rechecked the settings and the problem still persists.

Comment 3

9 years ago
I have the same problem on firefox 3.5.7

Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729) on win XP pro sp3

Automatic login does not work correctly (username and passwords are stored but auto connect does not work). I have tryied everything I know to try to fix this without success (safe-mode, clearing cookies and cache, new profil).

By the way, this is the first thing I noticed on this fresh install of FF 3.5.7 (was using FF 2 before), where I had only installed tab mix plus extension. I have never had this issue with firefox 2.

Exemple of website where the problem occurs:

http://www.clubic.com/
http://forum.hardware.fr/
http://www.911wheel.de/

Sometimes auto login worked (ie: I closed firefox, opened it again and was auto logged on theses website just by clicking their bookmarks) and I thought I had found the correct setting, but a few time later the issue reappears (ie: I have to click the login button of theses websites, when username and password are auto filled, or even have to type the first letter before clicking login button if username and pass are not auto filled).

Same bug was reported by Chris Palermo on firefox 2.0.0.3 (Bug 379421)
Lol, what is wrong with those links. German with English titles. Shorter link: 
http://support.mozilla.com/en-US/kb/Cannot+log+in+to+websites?bl=n

Comment 6

9 years ago
I have already read this and cannot get rid of this annoying issue. I am using FF for several years now, and even if I am new to FF v3.x.x I don't think it is a configuration/corruption problem (again, I noticed this on a fresh install).

This issue does not seem quite common, but according to bug reports here it seems to be real.
The problem is most like not in your installation folder so a reinstall might not help.
Try creating a new profile, import only your bookmarks and use this without any add-ons for a few weeks. Most likely it is an add-on that is responsible for the corruption of the cookie files.
(Reporter)

Comment 8

9 years ago
Hi Fred,
Try following steps:

1. Locate your profile folder - it's a randomly named subfolder of the
directory that opens when you hold down the "windows logo" key on your keyboard and press R then in that Run dialog paste %appdata%\Mozilla\Firefox\Profiles
and hit enter.
2. Ensure Firefox is closed using File -> Exit from menu, and check your Task
Manager processes tab to be sure there is no firefox.exe listed.
3. In the subfolder you found in step 1 find the file named cookies.sqlite and rename it to cookiesBACKUP.sqlite
4. Restart Firefox, log into your sites.
5. Restart firefox again and revisit the sites to see if it logs you in
automatically (if you have chosen "remember me" or other option on the sites.) 

It worked for me.

-Vaibhav

Comment 9

9 years ago
Ria, I already have tryied creating a new profil, but ok I tryied again for more testing. Here are the steps I followed:

exported bookmarks from previous profile in html format
firefox -p -> created new profil
imported bookmarks from htlm export done in first step
tryied with the websites listed in my previous post (clubic, forum.hardware.fr and 911wheel.de) and also added www.kegetys.net/forum/ (has a "always stay connected" button) and bugzilla with "remember" checked. 

I logged on those websites and clicked remind password button each time.

-If I switch from one to another in the same FF session (using their respective bookmarks) I stay logged.
-If I close FF and reopen it, I am still logged everywhere.
-If I close my windows session and reopen it and then open FF, I am not logged on any of thoses websites.

I also tryied with a new profil again, this time not even importing bookmarks and typing url by hand and had the same results as above.

For information, I also had a specific issue with 911wheel.de (only this one). I could reproduce it when it was occuring on the 1st new profil of this test but now it does not occur anymore, whatever FF profil I choose. This issue was this:

I logged to this website (it's a blog). Went away without closing the session of this site and came back and I was not logged anymore. 

-If I clicked on a link of this website my username appeared (ie I was logged in).
-If I clicked login button instead, then I got "access denied" page.

But as I said, even if it was reproduceable on my first tries, now this does not occur anymore. 

But the problem of not being automatically logged on website as soon as I exit my windows session is still there, even on a new profil without any extension nor even importing any bookmarks.
Do you have other software that deletes cookies?

Comment 11

9 years ago
Shame on me, CCleaner was clearing cookies...

I hope this entry will at least help avoiding some incorrect bug reports as mine was to compensate.

Sorry to have wasted your time with this and thank you for your help Ria and Vaibhav.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.