If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Strict DTD does not render UL or OL inside table with FONT tag

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
P3
normal
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Matthew Darwin, Assigned: harishd)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Using the <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">, the following
fragment shows just as plain text instead of an unordered list.


<TABLE><TR><TD>
<FONT>
<UL>
<LI> first bullet
<LI> second bullet
</UL>
</FONT>
</TABLE> 

This worked in previous mozilla builds (ie two months ago) but is not working
no today's build (ie 2000-09-13-12)

Removing the <FONT> and or <!DOCTYPE> tags makes the document render correctly.

Comment 1

17 years ago
The font tag is deprecated and not present in the strict dtd. This document does
not adhere to the doctype it promises. Further more the font tag is even not
allowed around an UL in transitional mode. IMHO this bug is invalid.

Comment 2

17 years ago
Agreed. This is invalid because under FONT cannot contain a list and the tag is 
deprecated under Strict DTD. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 3

17 years ago
Verifying bug invalid.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

17 years ago
I do not agree with this diagnosis.  The <FONT> tag is not defined in the
STRICT DTD, therefore its use in a document should not change the document's
behaviour (i.e. it should be ignored because it has no meaning).

Under the strict DTD, as implemented in mozilla, the behaviour of <FONT> is
different inside a table than outside a table.  This fundamentally makes no 
sense because IT SHOULD HAVE NO BEHAVIOUR AT ALL.

Reference:  http://www.w3.org/TR/1998/REC-html40-19980424/sgml/dtd.html
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 5

17 years ago
For absolute clarity, if I invent a tag called XFONT (just like I invented
the tag FONT). Mozilla works correctly under the STRICT DTD.  Here's
an HTML fragment I used to test:

<TABLE><TR><TD>
<XFONT>
<UL>
<LI> first bullet
<LI> second bullet
</UL>
</XFONT>
</TABLE> 

The behaviour of the two undefined tags FONT and XFONT should be identical,
but they're not.

Comment 6

17 years ago
I think (i may be wrong) that because the FONT tag cannot contain a list (per 
the Transitional DTD), then the parser will ignore the UL/LI tags and just 
render the contents, which happens to be text. But with your new example of 
using XFONT, I don't understand why Netscape 6 will render the contents as a 
list. I agree that the behavior should be the same but I will let Karnaze look 
at this. Attaching another testcase with TABLE v.s non-TABLE scenario and FONT 
v.s XFONT.

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

17 years ago
Created attachment 14757 [details]
expanded testcase

Comment 8

17 years ago
Testcase above uses Strict doctype

Comment 9

17 years ago
bug 48028 seems to be related.

Comment 10

17 years ago
I think this is a parser bug, the table code is more victim than the error
source. the table code should never get the information that there was a font
tag. I think this bug should be reassigned to rickg.

Comment 11

17 years ago
Harish, reassigning to you based on Bernd's comments.
Assignee: karnaze → harishd
(Assignee)

Comment 12

17 years ago
Strict DTD will not be supported in Mozilla. This bug will become invalid once 
strict DTD is turned off.
Status: NEW → ASSIGNED

Comment 13

17 years ago
Harish is right about the strictDTD. 

As far as the case goes, the fact that at is deprecated doesn't me it's "out". 
(There is another category for tags that are out). Deprecated tags may or may 
not be supported by a UA. We in fact support it. So the problem here (as the 
later testcase shows) is that <FONT> can't contain <UL> (inline doesn't contain 
block). So the testcase is invalid.

In the case of user-defined tags, we allow them in the content model, and they 
adopt the content type of their parent. 
(Assignee)

Comment 14

17 years ago
Strict DTD has been turned off. Shouldn't see the bug anymore. Marking WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 15

17 years ago
QA contact update
QA Contact: chrisd → amar
You need to log in before you can comment on or make changes to this bug.