Page layout is incorrect

VERIFIED DUPLICATE of bug 54565

Status

()

P3
normal
VERIFIED DUPLICATE of bug 54565
18 years ago
18 years ago

People

(Reporter: mwitbrock, Assigned: attinasi)

Tracking

({testcase})

Trunk
mozilla0.9.2
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Graphical elements misplaced, extra backgrounds.
Compare it to the rendering in (ick) IE
Over constrained table problem. It's the old 'width=100% is taking over' issue.
It seems legacy browsers actually pretty much ignored "width=100%" and treeated
it as "width=everything_you_have_left".

The testcase shows this clearly. Over to ChrisC and ChrisK.
Assignee: clayton → karnaze
Status: UNCONFIRMED → NEW
Component: Layout → HTMLTables
Ever confirmed: true
Keywords: 4xp, testcase
QA Contact: petersen → chrisd
Created attachment 14914 [details]
Minimised test case
Actually, this could just be the images-should-not-wrap compat issue...

Comment 4

18 years ago
I am still seeing this in Mozilla build 2001012205 Win32 build.

Comment 5

18 years ago
QA contact update
QA Contact: chrisd → amar

Comment 6

18 years ago
This is a dup of another bug (I can't find it). The 1st cell's block is 
returning a max element width smaller than the combined width's of the two 
images it contains (dump below). The table then reflows the 1st cell with the 
max element width since there is a 100% width cell in the table. This causes the 
images to appear on different lines. Reassigning to attinasi and moving to 
m0.9.2.

   Row 00CC85E0 r=0 a=UC,UC c=UC,UC cnt=337
    Cell 00CC8628 r=0 a=UC,UC c=1695,UC cnt=338
     Block 00CC8684 r=0 a=UC,UC c=UC,UC cnt=339
     Block 00CC8684 d=1695,1455 me=1455
    Cell 00CC8628 d=1695,1455 me=1455
    Cell 00CC88C8 r=0 a=UC,UC c=1365,UC cnt=340
     Block 00CC8924 r=0 a=UC,UC c=UC,UC cnt=341
     Block 00CC8924 d=1365,1365 me=1365
    Cell 00CC88C8 d=1365,1365 me=1365
    Cell 00CC8A80 r=0 a=UC,UC c=UC,UC cnt=342
     Block 00CC8ADC r=0 a=UC,UC c=UC,UC cnt=343
     Block 00CC8ADC d=60,285 me=60
    Cell 00CC8A80 d=60,285 me=60
Assignee: karnaze → attinasi
Target Milestone: --- → mozilla0.9.2
(Assignee)

Comment 7

18 years ago
This is a dup of 54565 me thinks.

*** This bug has been marked as a duplicate of 54565 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 8

18 years ago
I don't know what was fixed where, but sfnb.com renders the same in IE5.5 and
Mozilla for me.

The dup isn't fixed yet...

Comment 9

18 years ago
 This bug was fixed some where.. verified on Build ID # 2001-07-18-10-trunk
Win2k... Marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.