Pressing Shift+Enter when the location bar has focus can trigger unwanted page saving

RESOLVED INVALID

Status

SeaMonkey
Location Bar
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Prognathous, Unassigned)

Tracking

SeaMonkey 2.0 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
To reproduce:

1. Press Alt+D to focus the location bar
2. Press Shift+Enter

Result: The Page Save-As dialog opens

I frequently encounter this problem when I want to refresh a page without re-sending data. My intention is to focus the location bar and press Enter to reload the page, but on some keyboards (especially my laptop's) the *right Shift* button gets pressed inadvertently, making the Save As dialog pop up.

Even worse, sometimes the Save As dialog takes time to open and it feels as if the key press didn't register. In these cases I press Enter again, only to find that a split second earlier the dialog did open. Result: The page gets saved (actual flow is: Alt+D -> right Shift + Enter -> Enter.)

Since I actually use Shift+Enter occasionally to save pages, I don't want this feature removed. I do, however, think that it should only work with the *left Shift* button. This would retain the shortcut and prevent it from being triggered accidentally.

Prog.

Comment 1

8 years ago
It's not a bug, it's a feature. In other words: this behaviour is by design.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

8 years ago
Please read the whole report, not just the steps to reproduce. You missed a few key details.

Prog.
You need to log in before you can comment on or make changes to this bug.