sleep after a long delay

RESOLVED INVALID

Status

()

Core
General
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Chester Wong, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en; rv:1.9.0.15pre) Gecko/2009091516 Camino/2.0b4 (like Firefox/3.0.15pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en; rv:1.9.0.15pre) Gecko/2009091516 Camino/2.0b4 (like Firefox/3.0.15pre)

After downloading 2.0b4 sleep is delayed more than 30 seconds. Previous version (1.6.10) sleep happens in 1 to 2 seconds.

Reproducible: Always

Steps to Reproduce:
1.Select sleep from Apple menu with Camino 2.0b4 running
2.
3.



Dual 2 GHz PPC G5; 10.5.8

Comment 1

8 years ago
Can you still reproduce this with Camino 2.0.1?

Does it make any difference what pages are open when you sleep the computer?
(Reporter)

Comment 2

8 years ago
1. Yes, it happens with Camino 2.0.1 as well as Firefox 3.5.
2. It makes no difference even if there are no pages/windows open--all it takes is for Camino or FF running.

Comment 3

8 years ago
I'm going to kick this to Core for further triage, since it happens with Firefox, too, but while I'm doing that...

Is the computer actually hanging (i.e., do you see the spinning beachball) before it goes to sleep? What appears to be happening, if anything?
Component: General → General
Product: Camino → Core
QA Contact: general → general
(Reporter)

Comment 4

8 years ago
No spinning beachball--it just sits there for 30 seconds or so before sleeping. I've used Activity Monitor to see if Camino is using a lot of cpu cycles and it doesn't appear to be hogging the cpu. Also if I should try to keep the mouse moving in an attempt to cancel sleep, it just goes to sleep when it wants to.
(Reporter)

Comment 5

8 years ago
Having endured delayed sleep for weeks, I decided to change my default browser to Safari. Now my Mac goes to sleep in two seconds whether or not Camino or FF is running. ???????

Comment 6

8 years ago
Here's a shot in the dark...try rebuilding your LaunchServices database (something like Onyx will do the trick) and then re-set your default browser to either Camino or Firefox and see if there's any difference.

cl
(Reporter)

Comment 7

8 years ago
Thanks, Chris. Your shot in the dark worked like a charm.

Comment 8

8 years ago
INVALID, then, since it sounds like this was some sort of LaunchServices bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.