If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

download via "save link target" does not honor preference setting

RESOLVED DUPLICATE of bug 498152

Status

SeaMonkey
Download & File Handling
--
minor
RESOLVED DUPLICATE of bug 498152
8 years ago
8 years ago

People

(Reporter: Paul, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0

download via "right-click | save link target (ctrl-R)" does not honor the "Preferences | Downloads" setting of "save file to" location; instead it always presents the save-file dialog and requires the user to (at least) hit the ENTER key.

Note that the right-click menu does say "save link target" rather than "save link target as...", so that part at least did check the prefs.

Ideally the user should be able to do either "save" or "save as.." regardless of preference, by either ALWAYS presenting both right-click menu choices, or by testing for a modifier key and presenting the appropriate choice; it's a pain to have to change the preference for just one save (usually I want to just save using the default filename (with automatic rename if that name already exists), but sometimes I do want to save it under a specific filename)).


Reproducible: Always

Steps to Reproduce:
1. set pref to "save to location"
2. right click a link; menu says "save link target" as it should (no "as...")
3. but it still presents the file-save dialog.



this worked as (I) expected up through seamonkey 1.1.18; w/ version 2.0 it's acting differently.

Comment 1

8 years ago
Confirming on 2.0.1pre. "Regression" set as wanted.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
Version: unspecified → Trunk

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 498152
You need to log in before you can comment on or make changes to this bug.