[WINCE] Firefox does not start

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
9 years ago
8 years ago

People

(Reporter: İsmail Dönmez, Unassigned)

Tracking

Trunk
ARM
Windows CE
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: mothballed)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/532.4 (KHTML, like Gecko) Chrome/4.0.232.0 Safari/532.4
Build Identifier: 

I built Firefox from mozilla-central HG repository, using the suggested mozconfig from https://wiki.mozilla.org/Firefox/Tegra/Build_Notes . Copied the build to a WinCE 6.0 machine and clicked firefox icon, but the splash screen moves a little and then Firefox closes itself.

I tried to attach with the debugger but the application exists cleanly. There does not seem to be a crash.

Reproducible: Always

Steps to Reproduce:
1. Double click firefox.exe on the device
2. Notice that the splash screen is shown
3. Firefox closes itself before showing the main screen.
Actual Results:  
Firefox does not start.

Expected Results:  
Firefox shows the main screen.
(Reporter)

Updated

9 years ago
OS: Other → Windows CE
Hardware: Other → ARM
Version: unspecified → Trunk
(Reporter)

Comment 1

9 years ago
Btw using Visual Studio 2008 as the compiler.
(Reporter)

Comment 3

9 years ago
Tried firefox-3.7a1pre.en-US.wince-arm and trying to run Firefox.exe results in an error message box:

"Application FIREFOX.exe encountered a serious error and must be shut down."

Then the dialog box automatically closes itself.

The device have a Freescale i.MX31 CPU and 90mb of RAM.
(Reporter)

Comment 4

9 years ago
Tested my build on a Windows CE 5.0 device and the same problem happens, Firefox screen exits before finishing loading. Also it doesn't seem to be a memory problem since the system has 70mb of free RAM.

Comment 5

8 years ago
This year we mothballed windows mobile development.  See:

  http://blog.pavlov.net/2010/03/22/stopping-development-for-windows-mobile/

Marking bugs in the windows mobile / windows ce bucket as WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
Whiteboard: mothballed
You need to log in before you can comment on or make changes to this bug.