Firefox is sluggish or unresponsive for several seconds when Library window is open after a keyword search of history.

RESOLVED DUPLICATE of bug 556068

Status

()

--
major
RESOLVED DUPLICATE of bug 556068
9 years ago
8 years ago

People

(Reporter: eleven81, Unassigned)

Tracking

({perf})

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4

I noticed that after I searched through the history for a keyword (for example, 'truck'), if I leave the Library window open and go back to Firefox to browse some more, the UI becomes sluggish or unresponsive.  Things like scrolling, clicking between tabs, clicking form fields, typing usernames or passwords in input boxes, and really any other general browsing tasks happen much slower.

For instance, with the Library window open and search results loaded, sometimes it only takes two seconds to change tabs, sometimes it takes five or six.

In another instance, sometimes I can type my password and wait 5 to 10 seconds before it starts to appear in the input box, but other times it is almost as quick as when the Library window is closed.

The results are the same in Safe Mode on a clean profile, although the delays are shorter, presumably because the history is shorter on a clean profile.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox in Safe More with a clean profile.
2. Browse around to create a reasonable history of a hundred pages at least.
3. Press CTRL+SHIFT+H to load the Library window to search the history.
4. Search the history for a specific keyword, wait for the results to appear.
5. Minimize but do not close the Library window, and continue browsing as usual.  Try scrolling, try changing tabs, try loading new sites, try entering data in forms.  Browse as usual.
Actual Results:  
Notice that browsing seems much slower and Firefox feels much less responsive, even sluggish.

Expected Results:  
Having the Library window open with search results loaded should have no effect perceived browsing speed or perceived browser responsiveness.  Firefox should act normally and not be sluggish and unresponsive for several seconds.

Updated

9 years ago
Component: General → Bookmarks & History
Keywords: perf
QA Contact: general → bookmarks
Version: unspecified → 3.5 Branch
I can reproduce on trunk.  Maybe bug 490714 will fix this.

Comment 2

8 years ago
I can also confirm this. Bug 490714 might help this, but won't fix the problem. The library window shouldn't do anything while its in the background or minimized.

Comment 3

8 years ago
Marking as a duplicate of a more active bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 556068
You need to log in before you can comment on or make changes to this bug.