Last Comment Bug 526264 - 'No timezones found' error during startup, calendars not visible
: 'No timezones found' error during startup, calendars not visible
Status: VERIFIED FIXED
: regression
Product: Calendar
Classification: Client Software
Component: Lightning Only (show other bugs)
: Trunk
: All All
: -- critical (vote)
: 1.0b1
Assigned To: Stefan Sitter
:
Mentors:
: 526419 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-03 10:15 PST by Stefan Sitter
Modified: 2010-02-04 11:05 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
bustage fix (1.54 KB, patch)
2009-11-03 10:38 PST, Stefan Sitter
philipp: review+
Details | Diff | Review

Description Stefan Sitter 2009-11-03 10:15:03 PST
It looks like something in the patch for Bug 470430 broke Lightning 1.0pre. If you install the 20091103 build into an existing profile it fails with timezone errors on the next startup:

[calTimezoneService] using D:\dev\apps\thunderbird\extensions\calendar-timezones@mozilla.org\timezones.sqlite

Error: No timezones found! Please install calendar-timezones.xpi.

Error: [Exception... "'<error>' when calling method: [calICalendar::uri]"  nsresult: "0x804a0008 (<unknown>)"  location: "JS frame :: file:///[...]/calendar-js/calCalendarManager.js :: cmgr_createCalendar :: line 613"  data: no]

Error: uncaught exception: [Exception... "'[JavaScript Error: "this.mSelectByTzid is undefined" {file: "file:///[...]/calendar-js/calTimezoneService.js" line: 237}]' when calling method: [calITimezoneService::defaultTimezone]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://calendar/content/calUtils.js :: calendarDefaultTimezone :: line 212"  data: yes]
Comment 1 Stefan Sitter 2009-11-03 10:27:08 PST
I think the problem might be caused by this cleanup:

> -  var extMgr = Components.classes["@mozilla.org/extensions/manager;1"]
> +  let extMgr = Components.classes["@mozilla.org/extensions/manager;1"]

http://hg.mozilla.org/releases/comm-1.9.1/annotate/0e1adb3b9ac8/calendar/base/src/calTimezoneService.js#l146

But extMgr is later accessed outside this scope and fails.
Comment 2 Stefan Sitter 2009-11-03 10:38:40 PST
Created attachment 409967 [details] [diff] [review]
bustage fix
Comment 3 Philipp Kewisch [:Fallen] 2009-11-03 12:00:28 PST
Comment on attachment 409967 [details] [diff] [review]
bustage fix

Looks good. If this is not it, did you remove the stray extensions directory as noted in bug 470430?
Comment 4 Philipp Kewisch [:Fallen] 2009-11-03 12:02:19 PST
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/1533f0738a3a>
and comm-1.9.1 <http://hg.mozilla.org/releases/comm-1.9.1/rev/520d6289316f>

-> FIXED
Comment 5 Stefan Sitter 2009-11-03 12:19:16 PST
(In reply to comment #3)
> If this is not it, did you remove the stray extensions directory as
> noted in bug 470430?

I did not found this directory on my system and it is not related to this bug. This bug occurs because we access undefined |extMgr| in case of Lightning, trigger an exception and fallback to the unit test section in the code linked above.
Comment 6 Martin Schröder [:mschroeder] 2009-11-03 23:58:25 PST
*** Bug 526419 has been marked as a duplicate of this bug. ***
Comment 7 Martin Schröder [:mschroeder] 2009-11-04 07:44:54 PST
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.4pre) Gecko/20090915 Lightning/1.0pre Thunderbird/3.0b4... Lightning build id: 20091104034447
Comment 8 Martin Schröder [:mschroeder] 2009-11-04 14:46:58 PST
*** Bug 526617 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.